WordPress.org

Ready to get started?Download WordPress

Forums

Related Posts Thumbnails
[resolved] Related Posts Thumbnails Settings breaks validation (5 posts)

  1. chrissss
    Member
    Posted 3 years ago #

    When i check my page for xhtml errors, i find for every "related thumbnail" an error like...

    Error Line 179, Column 464: document type does not allow element "div" here; missing one of "button", "map", "object", "ins", "del", "noscript" start-tag

    The mentioned element is not allowed to appear in the context in which you've placed it; the other mentioned elements are the only ones that are both allowed there and can contain the element mentioned. This might mean that you need a containing element, or possibly that you've forgotten to close a previous element.

    One possible cause for this message is that you have attempted to put a block-level element (such as "<p>" or "<table>") inside an inline element (such as "", "<span>", or "<font>").

    I think the problem is caused by the <div>...</div> structure you're using...


    <div style="clear: both"></div><div style="border: 0pt none ; margin: 0pt; padding: 0pt;"><div style="border: 0pt none; margin: 0pt; padding: 0pt; width: 107px; height: 182px;"><div style="border: 0pt none; margin: 0pt; padding: 0pt; background: transparent url(http://example.org) no-repeat scroll 0% 0%; -moz-background-clip: border; -moz-background-origin: padding; -moz-background-inline-policy: continuous; width: 107px; height: 107px;"></div><div style="border: 0pt none; margin: 3px 0pt 0pt; padding: 0pt; font-family: Arial; font-style: normal; font-variant: normal; font-weight: normal; font-size: 12px; line-height: normal; font-size-adjust: none; font-stretch: normal; -x-system-font: none; color: #333333;">Example</div></div>...

    You can see the error in "action" at http://linuxundich.de/de/ubuntu/endlich-google-mail-voice-und-video-chat-fur-linux/

  2. chrissss
    Member
    Posted 3 years ago #

    > I think the problem is caused by the <div>...</div> structure you're using...

    This should have been <div>...</div>

  3. chrissss
    Member
    Posted 3 years ago #

    Last try...

    This should have been <a href="..."><div>...</div></a>

  4. marynixie
    Member
    Plugin Author

    Posted 3 years ago #

    Hi chrissss, that's right default plugin HTML causes validation errors in some document types. I added the new output style "List" in plugin settings which produces cleaner HTML without validation errors, but for compatibility reasons with previous versions it is not the default setting. Try to use this new output style.

  5. chrissss
    Member
    Posted 3 years ago #

    Great, this solved all these errors! Thanks!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic