WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
[resolved] Related Posts Not Showing When Logged Out (10 posts)

  1. Thomas McMahon
    Member
    Posted 5 months ago #

    I enabled Related Posts and I have it set to show large image. When I'm logged in, it works great. When I'm logged out, nothing appears.

    http://www.twistermc.com/40715/stock-footage-commercial/

    Indexing is at 100%.

    I'm wondering if related posts fail when there is caching in place. I run both WP Super Cache and Cloudflare. However, other features of JetPack work just fine so I'm not sure why this one would fail.

    https://wordpress.org/plugins/jetpack/

  2. kiwimana
    Member
    Posted 5 months ago #

    Hi,

    Similar issues, but nothing showing if logged on not.

    How did you check your site was indexed?

    Cheers...Gary

  3. Thomas McMahon
    Member
    Posted 5 months ago #

    Go to the JetPack page in your blog then scroll down to Related Posts and click Learn More.

    In that box it'll tell you the index status.

  4. kiwimana
    Member
    Posted 4 months ago #

    Hi,

    It looks like WP Super Cache doesn't work with Related Posts, I disabled caching on this and the related posts are now showing up.

    Thanks

    Gary Fawcett

  5. Thomas McMahon
    Member
    Posted 4 months ago #

    Any ideas on how to make this work? Other related plugins work fine with caching plugins.

  6. Richard Archambault
    Happiness Engineer
    Plugin Author

    Posted 3 months ago #

    Hi Thomas, do you still have this issue?

  7. kiwimana
    Member
    Posted 3 months ago #

    Not sure about Thomas, but I still do tried lots of ideas.

    In the end I disabled WP Super Cache and the related posts are back. I will turn it back on when I find out a way to make these two great plugin work well together.

    Thanks

    Gary

  8. Thomas McMahon
    Member
    Posted 3 months ago #

    I've come to the conclusion that Related Posts in JetPack don't work with caching plugins so I've given up. I'd love to get it working however.

  9. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 3 months ago #

    Related Posts used to work with WP Super Cache, but I can now reproduce this problem. WP Super Cache seems to cache the call to Related Posts, even if you check "Don’t cache pages with GET parameters. (?x=y at the end of a url)" in your WP Super Cache settings.

    You can check this by adding ?relatedposts=1 to one of your post URLs; if you use WP Super Cache, you'll load the post. If you don't use WP Super Cache, you'll get a list of Related Posts.

    We'll take a closer look at this and see if we can find a work around in Jetpack, or fix the problem in WP Super Cache. Thanks for the reports!

  10. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 3 months ago #

    I had another look, and it was a mistake on my own site. Related Posts do indeed work with WP Super Cache and CloudFlare. I use all 3 on my own site without any issues.

    @Thomas It seems to be working on your site as well.

    If you still experience issues, could you post your site URL here so I can have a look?

    If you want it to remain private, you can also contact us via this contact form:
    http://jetpack.me/contact-support/

Reply

You must log in to post.

About this Plugin

About this Topic

Tags