WordPress.org

Ready to get started?Download WordPress

Forums

Related Posts Links Broken (11 posts)

  1. Jamie G Man
    Member
    Posted 5 years ago #

    Hi my "related post" are broken on the individual blog page posts. They are missing the question mark and are going to 404 pages. Is there any way to fix this or disable them for the blog?

  2. Jamie G Man
    Member
    Posted 5 years ago #

    Anyone?

  3. Jamie G Man
    Member
    Posted 5 years ago #

    Can anyone help me or help me out with a link that will help me? I really can't figure this one out.

  4. billhood
    Member
    Posted 5 years ago #

    Jamie, I have had the same problem and I am currently looking for an answer to this predicament. Did you recently upgrade to WordPress 2.7? That's when it happened to me.

    There are a few workarounds listed in the forum here, but none are working for me.

  5. billhood
    Member
    Posted 5 years ago #

    I tried going back to WP v2.63, but the links are still broken. They are still missing the question mark.

  6. billhood
    Member
    Posted 5 years ago #

    Still no resolve. I have looked everywhere for an answer to this, but so far - Nothing!

    My Recent Post tags do not have the "?" and thus return an error. It seems that a good many folks are having the same problem, but I have seen nothing about a resolve yet.

    Does anyone have an answer to this? I'd settle for not having the Recent Post links at all, rather than having them dead end to nowhere. Any suggestions? Anyone?

  7. Jamie G Man
    Member
    Posted 5 years ago #

    Hi bill, nice to see I am not the only one with this issue. It is driving me NUTS! I still can't figure it out. I didn't upgrade my blog I am using 2.6.3 version. Your right they are missing the question mark in the link URL. I can't figure it out. It really sucks having this list of useless links on every single blog page. You would think someone would know the answer to why these links are on my page. I don't have one single plug in that has anything to do with Related posts. I am using the self install .com version of wordpress and there is no way to get rid of these links.

  8. iridiax
    Member
    Posted 5 years ago #

    Related posts are not a standard part of WordPress, so it's likely plugin or theme-related. To see if it is a plugin causing it, temporarily disable all plugins and see if the problem goes away. To see if it's your theme, switch to the default theme and see if the problem goes away.

  9. Jamie G Man
    Member
    Posted 5 years ago #

    I found it. It is StatsPressCN module that is adding these links and they are broken I will go the that module and report it to them. I have no idea why this module would add these annoying related links to my posts pages they have been driving me nuts.

  10. Jamie G Man
    Member
    Posted 5 years ago #

    The best part is that it is right in the plugins page description. I would have never though. I am going to ask they fix it or remove it. It doesn't work very well at all.

  11. Jamie G Man
    Member
    Posted 5 years ago #

    Ok under StatpressCN under "options" there is a checkbox called "Show related post at the tail (After your blog is visited 1000 times, then you can use this function. Now the number is 163537)" I disabled it and it is now GONE!!! :) Happy times that I finally figured this one out. Thanks for your advice iridiax.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.