WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Related Posts in Sidebar Problem (6 posts)

  1. sinclasc
    Member
    Posted 7 years ago #

    Hi,
    I'm using Related Posts with the associated sidebar plugin. My problem is that the posts listed in the sidebar seem to have no line break to seperate them; they appear in a list with no space, as demonstrated on the url below. Any ideas?

    http://www.realepicurean.com/index.php/main-page-news/family-cookbook/

  2. KatGirl
    Member
    Posted 7 years ago #

    You're missing the opening & closing <li> in your list.

    You have:

    <li id="related-posts" class="widget widget_related_posts"><h2 class="widgettitle">Similar Items</h2>

    <ul><a href="#" rel="bookmark" title="Permanent Link: Sauerkraut">Sauerkraut</a><a href="#" rel="bookmark" title="Permanent Link: Fettuccine all’amalfitana">Fettuccine all’amalfitana</a></ul></li>

    This is the code I use:

    <?php related_posts(5, 10, '<li>', '</li>', '', '', false, false); ?>

    See how the opening and closing <li> are stated in the Related Post code.

    FN: Links deliberately edited

  3. sinclasc
    Member
    Posted 7 years ago #

    I'm still not sure how to edit the script from the plugin to make this work...I assumed it would work out of the box but it seems not to.
    Can anyone illustrate how I need to change the code to do this?

  4. Doodlebee
    Member
    Posted 7 years ago #

    Did you get this fixed? I checked it in Firefox and IE6 - I don't see this issue in either browser. (View source shows all LI tags *are* closed...)

    If not, what are you viewing it through?

  5. sinclasc
    Member
    Posted 7 years ago #

    Hi,
    Didn't get it fixed.
    Viewing with Firefox (home) and IE6 (work).

  6. Doodlebee
    Member
    Posted 7 years ago #

    I swear, I do not see this issue.

    I went to the index page of your site, and the only thing I saw that was even remotely *close* to being an issue was the "Welcome to RealEpicurian.com" was on two lines instead of one.

    But all of your list items look fine...I honestly don't see the issue. (This is the second post today where I don't see the problem, so maybe it's just me?)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags