WordPress.org

Ready to get started?Download WordPress

Forums

ELI's Related Posts Footer Links and Widget
[resolved] related posts are URLs instead of hyperlinks (5 posts)

  1. zaiczen
    Member
    Posted 1 year ago #

    Hi Eli,

    I'm a big fan of the plugin, but lately, some of the related posts show up as URLs that aren't hyper-linked. The number of non-linked URLs varies each time the page is refreshed and even the particular posts that aren't linked changes. Here's a page that provides an example:

    http://cruxref.com/?cat=4

    Every time you refresh the page, a different set of the URLs show up un-linked. Any suggestions?

    http://wordpress.org/extend/plugins/spostarbust/

  2. Eli
    Member
    Plugin Author

    Posted 1 year ago #

    It looks like the calls to the_title() are failing on certain posts. It may be because of something in the title that cannot be returned to a string variable or else something wrong with the date of date format on these same posts.

    The best example I see is on http://cruxref.com/?p=1507
    Whenever the following posts show up as any of the three links it drops all the formatting returned by the_title():
    http://cruxref.com/?p=1482
    http://cruxref.com/?p=1476
    http://cruxref.com/?p=121
    http://cruxref.com/?p=4772
    http://cruxref.com/?p=817
    http://cruxref.com/?p=597

    Can you look into the title and date fields on these posts for anything that could be causing this?

    You could also try turning off the date on the related posts to see if it's the just the date field or just the title field.

    Please let me know what you find.

    Aloha, Eli

  3. Eli
    Member
    Plugin Author

    Posted 1 year ago #

    It looks to me like the posts mentioned above do not actually have titles at all and that is why they are displaying like that.

  4. zaiczen
    Member
    Posted 1 year ago #

    I can't believe I didn't think of this myself.

    I'm trying to develop a new format for posts that emphasizes the tags, so I've been including the title-like information in the body of the post. I should have known this would cause an issue. This thread probably won't be useful to many others though, as most people make use of the title field.

    Is there any way that the plugin can be directed to utilize the first words in the body of the post as a basis for the related link? If there isn't, I understand. Thanks for looking into this for me and thanks for developing such a useful tool.

  5. Eli
    Member
    Plugin Author

    Posted 1 year ago #

    Not without a heck of a lot of hacking.

    What I would do, it I were you would be to enter in titles for all the posts, but then hack the theme so that the titles are not displayed.

    You could probably even add a function that auto generates a title when the post is added.

    Aloha, Eli

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic