WordPress.org

Ready to get started?Download WordPress

Forums

WordPress Related Posts
[resolved] Related Post using NextGEN Gallery featured images (5 posts)

  1. Just a Stranger
    Member
    Posted 9 months ago #

    Hello,

    I am facing an issue regarding the display on the "Featured post" of a WordPress Install that works like this.

    1. It's a 3 languages website using http://wpml.org/ plugin (last version)
    2. Has over 100 articles (translated in all the 3 languages - ex website.com/en , /hu (Magyar) & the default is in romanian)
    3. Each of the plugin has a NexGen Galley

    I have used to set a featured image an image from the NextGen Gallery for 80% of the articles, and for the rest of the 20 they were set "manual" ... I did that so I would't have to reupload the same image again ...

    Now I want to set this plugin to give me the related post, at the bottom but I a facing the following difficulties.

    1. On /en I have featured post in /hu or romanian
    2. The NextGen Gallery featured pictures are not shown.

    Example http://oi39.tinypic.com/mtuvyg.jpg

    Thank you in advance ... for any advice :)

    http://wordpress.org/extend/plugins/wordpress-23-related-posts-plugin/

  2. silvoslaf
    Member
    Plugin Author

    Posted 9 months ago #

    Hey!

    Hm, well, this sure sounds a bit confusing but allow me to play around with this NextGen Gallery plugin a bit on our test blogs and to figure it out how it works.

    But for that first problem with English related posts on your Romanian part of the site — try to categorize those English blogposts into one special category and later exclude them from showing up in your blogposts all together. You can set that up in your plugin settings.

    Let me know if this helped in any way while I will get back to you with some more updates on that second (featured image) problem.

    Thanks & hear us soon!

    Take care!

    Silvo

  3. silvoslaf
    Member
    Plugin Author

    Posted 9 months ago #

    Hey!

    I installed the NextGen Gallery plugin and played around with it for a while, after which I can confirm your problem with the featured image setting.

    Unfortunately, I found no other option in the plugin settings that could make it communicate with our plugin, which is probably the reason why we should make some further adjustments to our plugin. But I'm afraid to say that we don't know how this will meet with our development process, which probably means that it could take us a while until this will be fixed.

    But we did push it into our organisation plan and we certainly hope we'll be able to fix it as soon as possible. In the meantime, I would suggest you to mark images as featured the old way or insert those images into your blogposts that you would like to see as thumbnails in your related posts.

    Let me know if you have any more questions or if you need any additional assistance — I'll gladly help!

    Take care & have a nice day!

    Best,
    Silvo

  4. fanfarek
    Member
    Posted 6 months ago #

    I had the same problem and I found simple solution, which is sufficient for me:

    Version: 2.9, File: thumbnailer.php, Line: 315

    In this place I changed code to:

    if (has_post_thumbnail(filter_var($related_post->ID, FILTER_SANITIZE_NUMBER_INT))) {
      return get_the_post_thumbnail( filter_var($related_post->ID, FILTER_SANITIZE_NUMBER_INT), 'post-thumbnail', array( 'title' => esc_attr( $post_title ), 'alt' => esc_attr( $post_title ) ) );
    }

    And also for my theme I have the following settings defined:

    add_theme_support( 'post-thumbnails' );
    set_post_thumbnail_size( 150, 150, true);
    add_image_size( 'featured', 700, 300 );
  5. silvoslaf
    Member
    Plugin Author

    Posted 6 months ago #

    Hey @fanfarek, I'm glad you found a work-around on this, really! :)

    Hope this will help our other users as well, if they encounter this issue with the NextGen Gallery. So big thank you from our team, very much appreciated!

    Hope nobody minds, but I'm going to mark this topic as resolved for the time being.

    Take care & have a nice rest of the day!

    Best,
    Silvo

Reply

You must log in to post.

About this Plugin

About this Topic

Tags