WordPress.org

Ready to get started?Download WordPress

Forums

Shareaholic | share buttons & related posts
Related page problem and ideas (6 posts)

  1. eldenroot
    Member
    Posted 8 months ago #

    Last version of your plugin is OK, I switched to v7 again ;)

    But there are some problems or ideas which could be useful:
    1) Make "Sexy sharing bar" smaller, or add this option
    2) Related content - I hate this [whats this] message under my related post content (text version)! - fixed, I found the option for this
    3) Is possible to disable Sharing bar/related content for mobile devices? It could be excellent!
    4) Another problem - my websites use plugin which secure my images and protect them from hot linking. My domain is whitelisted in this plugin but pictures in related content are shown that are hot linked... (so please tell mw which adress to add to the whitelist)
    5) add an option for related content to show only equal numbers of posts and add align position...

    Thats all for now, it is almost perfect plugin.... ;)

    http://wordpress.org/plugins/shareaholic/

  2. eldenroot
    Member
    Posted 8 months ago #

    EDIT:
    2) fixed - see above
    3) fixed - it just stopped showing on mobile phone (both - related content and sharing bar)

    4) I whitelisted s3.amazon server - http://shrimgs.s3.amazonaws.com but it still doesnt work
    5) see my another post there

  3. Celeste - Shareaholic
    Member
    Posted 8 months ago #

    Hi eldenroot,

    1) There are size options in your settings. Just head to the Available Apps page and click the Edit button to customize your share bar.

    3) Our apps should be visible in mobile. The new plugin is fully responsive. Did you add a media query to disable them in mobile, or did they just suddenly stop displaying?

    4) If you do not want images used for the Related Content app, you can also select an option to use a plain hyperlink list.

    5) The Related Content app shows 'up to' five recommendations. This depends on the size of the parent container. If you'd like to decrease the number shown, but keep the responsiveness, you can manually add the app via shortcode into your template file and wrap it with a div that you can style to your width specifications.

    ** but if you are not wanting images to display for the recommendations and opt to use a hyperlink list, you won't need to worry about #5.

  4. eldenroot
    Member
    Posted 8 months ago #

    1) Ok, select "Sexy theme" below the post setting and there you have only one size :) Please add "mini" or smaller size for this theme

    3) They are not, at least not on my phone SGS S3... it was suddenly, I didnt change anything

    4) I would like to use them, but tell me the url of the server which you use for thumbnails

    5) see point 4

    See ya

    BTW - Czech tranlation was sended, I hope it will be in the next release ;)
    - and please consider point 1) and option for enable/disable for mobile phones ;)

  5. Celeste - Shareaholic
    Member
    Posted 8 months ago #

    1) I see; you were asking about the sizes of the Related Content app's recommendations. We have applied some smart sizing parameters in our scripts to handle the dimensions of each list item (recommendation) that both resizes and works responsively to hide additional cards on smaller screens, and we are also working on a mobile version to make the app even more friendly for those who browse the internet on their mobile device.

    In the meantime, if you'd like, you can set media queries to hide specific apps from displaying in the mobile version of your site. You can add this into your blog's stylesheet in a media query and target individual apps by the data app id attribute, for example:

    [data-app-id="xxx"] {display:none;}

    where xxx is the app ID number that you can find at the bottom of the Edit screen for the app you configure on the Available Apps screen.

    Alternatively, you can use the following in a media query (which specifies screen resolution limits) to disable all Related Content apps:

    [data-app="recommendations"] {display:none;}

    3) Could you check if clearing your browser cache fixes the problem? Are you also able to check if this is the case when viewed through other browsers on your phone? And could you please compare your results to this page to see if the share buttons are visible while you are testing in different browsers?

    4) Are you only having trouble with the images appearing alongside the post titles in the recommendations? or is the app failing to display altogether? Would you mind directing me to a post where our Related Content app is set to appear so that I can take a look and ensure that I give you the correct information?

    Thanks!

  6. eldenroot
    Member
    Posted 7 months ago #

    Thank you for update and new theme for related post... ;)

    So now add customization for related posts - select category, page, etc and it will be excellent ;)

    About mobile and sharing bars - I dont see them, maybe it is theme related (I hava mobile theme activated, so maybe it is the problem... but it solved my problem with shareaholic and missing disable for mobile devices :))

    But I will be happy if you ad this option to shareaholic (just display resolution check)

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.