WordPress.org

Ready to get started?Download WordPress

Forums

Reinstall what?! (19 posts)

  1. nolascoj
    Member
    Posted 5 years ago #

    I just downloaded the install kit for wordpress and installed it originally in a /Apasu_blog..., but I wanted to change it to /blog... So I renamed the directory in hopes that it would work, but it didn't. So I deleted the directory and reinstalled it into a /blog.html, but then it says 'You appear to have already installed WordPress. To reinstall please clear your old database tables first.'

    I thought clearing my webbrowser would work, it didn't. Deleting the directory and restarting my filezilla, it didn't. What can I do? I WANT it to be /blog... not /Apasu_blog...

  2. MichaelH
    Member
    Posted 5 years ago #

    You will want to delete the database tables that were created when you first installed.

    You can just use phpMyAdmin to DROP all those tables.

  3. dreamslug
    Member
    Posted 5 years ago #

    I'm having the same problem.
    I went to my phpMyAdmin.
    I have Database and a user (two actually, I created another one accidentally)
    But I see no "tables"
    What tables do I need to delete?

  4. dreamslug
    Member
    Posted 5 years ago #

    This is the page I get:
    >
    WordPress
    '.__('Already Installed').'

    '.__('You appear to have already installed WordPress. To reinstall please clear your old database tables first.').'
    ');} switch($step) { case 0: case 1: // in case people are directly linking to this display_header(); ?>

    ReadMe documentation at your leisure. Otherwise, just fill in the information below and you\'ll be on your way to using the most extendable and powerful personal publishing platform in the world.'), '../readme.html'); ?>

    error) ) wp_die($wpdb->error->get_error_message()); display_header(); // Fill in the data we gathered $weblog_title = stripslashes($_POST['weblog_title']); $admin_email = stripslashes($_POST['admin_email']); $public = (int) $_POST['blog_public']; // check e-mail address if (empty($admin_email)) { // TODO: poka-yoke die('

    '.__("ERROR: you must provide an e-mail address.").'
    '); } else if (!is_email($admin_email)) { // TODO: poka-yoke die('

    '.__('ERROR: that isn’t a valid e-mail address. E-mail addresses look like: username@example.com').'
    '); } $wpdb->show_errors(); $result = wp_install($weblog_title, 'admin', $admin_email, $public); extract($result, EXTR_SKIP); ?>

    admin

    '.__('Note that password carefully! It is a random password that was generated just for you.').''; ?>

  5. dreamslug
    Member
    Posted 5 years ago #

    I already deleted ALL the files I uploaded and reloaded them. I still get the same page and no new "password" What password is it talking about?
    And what "tables" if not those included in files I uploaded?

  6. cunagh
    Member
    Posted 5 years ago #

    Hi

    dreamslug, did you every solve this problem?

    I am having the same issue. On other forums people recommend deleting tables in their phpmyadmin. I have no tables to delete in my wordpress database. i have created new databases and uploaded wordpress a number of times (with my wp-config.php details correct.)

    each time i go to http://www.example.ie/wordpress/wp-admin/install.php I get the same messge as above, ie:

    '.__('Already Installed').'

    '.__('You appear to have already installed WordPress. To reinstall please clear your old database tables first.').'
    ');} switch($step) { case 0: case 1: // in case people are directly linking to this display_header(); ?>

    can anyone help me solve this?

  7. cunagh
    Member
    Posted 5 years ago #

    my php was not enabled. once my provider enabled php it worked.

  8. Samuel B
    moderator
    Posted 5 years ago #

    @ dreamslug
    you also need to enable php

  9. jdinardo6
    Member
    Posted 5 years ago #

    Dreamslug & cunagh,
    I'm having the same problem. (already installed.....message). If you either of you figure out the problem let me know. I'll do the same.

    jdinardo6@aol.com

  10. Samuel B
    moderator
    Posted 5 years ago #

    @ jdinardo6
    cunagh's problem is already fixed.
    As noted, dreamslug has the same error and just needs php enabling.
    is your error exactly the same? i.e. no formatting? or better yet, just post the error message exactly.

  11. jdinardo6
    Member
    Posted 5 years ago #

    Thanks samboll, here is what i'm getting:

    '.__('Already Installed').'

    '.__('You appear to have already installed WordPress. To reinstall please clear your old database tables first.').'
    ');} switch($step) { case 0: case 1: // in case people are directly linking to this display_header(); ?>

    ReadMe documentation at your leisure. Otherwise, just fill in the information below and you\'ll be on your way to using the most extendable and powerful personal publishing platform in the world.'), '../readme.html'); ?>

    error) ) wp_die($wpdb->error->get_error_message()); display_header(); // Fill in the data we gathered $weblog_title = isset($_POST['weblog_title']) ? stripslashes($_POST['weblog_title']) : ''; $admin_email = isset($_POST['admin_email']) ? stripslashes($_POST['admin_email']) : ''; $public = isset($_POST['blog_public']) ? (int) $_POST['blog_public'] : 0; // check e-mail address if (empty($admin_email)) { // TODO: poka-yoke die('

    '.__("ERROR: you must provide an e-mail address.").'
    '); } else if (!is_email($admin_email)) { // TODO: poka-yoke die('

    '.__('ERROR: that isn’t a valid e-mail address. E-mail addresses look like: username@example.com').'
    '); } $wpdb->show_errors(); $result = wp_install($weblog_title, 'admin', $admin_email, $public); extract($result, EXTR_SKIP); ?>

    admin

    '.__('Note that password carefully! It is a random password that was generated just for you.').''; ?>

  12. Samuel B
    moderator
    Posted 5 years ago #

    ok - that is the same exact error.
    Enable php 5.x.x in your host control panel or ask them to do it if that's not an option.
    Once that's done - good to go

  13. dobrak
    Member
    Posted 5 years ago #

    Could my problem http://wordpress.org/support/topic/235109? be, that I have "only" PHP 4.3.4 and not 5.x.x - even if only 4.3 is required at http://codex.wordpress.org/Hosting_WordPress

    Hmmm ... interestingly it has worked with 4.3.4 before this reinstallation issue.

  14. JashaM
    Member
    Posted 5 years ago #

    I have the same error message but I called my host and they updated it but its still getting the same error? Does it take a day to turn on or something?? :0/

  15. Jester82
    Member
    Posted 5 years ago #

    im having the same problem with a website i am personally hosting and i cannot find where i should be enabling php5 is it in phpadmin or on my linux server itself. thank you in advance

  16. Samuel B
    moderator
    Posted 5 years ago #

    if you own the server it is something you have to install on the server
    normally it is in the host control panel...

    if php5 is installed
    try adding this to top of .htaccess
    AddHandler x-httpd-php5 .php

  17. Jester82
    Member
    Posted 5 years ago #

    i added the line to the top of the .htaccess file.
    i get a prompt asking me if whether i want to open index.php as with different application or if i want to save the file.

    was i supposed to put the addhandler in the <ifModule> tag or before it
    like i did

    or did i just totally mess everything up

  18. hi5haylz
    Member
    Posted 5 years ago #

    Hi there,

    I'm having the same problem. I'm very new to all this so could anybody explain the steps to enable php5? I'm using cPanel X.

    Thanks!

    Haylz

  19. kassy4
    Member
    Posted 5 years ago #

    Hi there,

    I had the same problem installing wordpress locally using MAMP. It was fixed by opening up the install file properly.

    I was originally trying to open it from this location:
    THIS IS WRONG!
    file:///Applications/MAMP/htdocs/wordpress/wp-admin/install.php

    THIS ONE WORKS:

    http://localhost:8888/wordpress/wp-admin/install.php

    Idiot move, but wasted two hours of my life trying to figure out why I was getting your same error. Hopefully that saves someone else some time.

Topic Closed

This topic has been closed to new replies.

About this Topic