WordPress.org

Ready to get started?Download WordPress

Forums

The Google+ plugin
[resolved] Regular apiAuthException? (6 posts)

  1. gothickmatt
    Member
    Posted 1 year ago #

    I'm seeing a regular exception coming from the plugin in my error logs. Any hints as to what might be causing it?

    Thanks,

    Matt

    [Tue Apr 16 07:57:26 2013] [error] [client 204.62.14.81] PHP Fatal error:  Uncaught exception 'apiAuthException' with message 'Error refreshing the OAuth2 token, message: '{\n  "error" : "invalid_request"\n}''
     in /var/www/sites/wordpress/html/wp-content/plugins/google/lib/external/google/auth/apiOAuth2.php:241\n
    Stack trace:\n
     #0 /var/www/sites/wordpress/html/wp-content/plugins/google/lib/external/google/auth/apiOAuth2.php(200): apiOAuth2->refreshToken('1/VxNwSeS4oIvO2...')\n
     #1 /var/www/sites/wordpress/html/wp-content/plugins/google/lib/external/google/io/apiCurlIO.php(45): apiOAuth2->sign(Object(apiHttpRequest))\n
     #2 /var/www/sites/wordpress/html/wp-content/plugins/google/lib/external/google/io/apiREST.php(55): apiCurlIO->authenticatedRequest(Object(apiHttpRequest))\n
     #3 /var/www/sites/wordpress/html/wp-content/plugins/google/lib/external/google/service/apiServiceResource.php(151): apiREST::execute(Object(apiServiceRequest))\n
     #4 [internal function]: apiServiceResource->__call('list', Array)\n
     #5 /var/www/sites/wordpress/html/wp-content/plugins/google/lib/class_wdgpo_google_auth.php(139): Activit in /var/www/sites/wordpress/html/wp-content/plugins/google/lib/external/google/auth/apiOAuth2.php on line 241

    http://wordpress.org/extend/plugins/google/

  2. Since this is reported as a PHP Fatal Error, you should have seen a white screen or something else indicating that there's something wrong...
    Is this an old message or is it a re-occurring one?

    Please advise,
    Ari.

  3. gothickmatt
    Member
    Posted 1 year ago #

    It recurs about once an hour if I enable the plugin. I guess at that point, whoever views that page gets a white screen instead of my blog, which has happened to me occasionally when viewing it.

  4. I see.
    I know what I'm about to ask sounds like a lot of trouble but it will have to be done if we're going to pin-point the cause of this since I can't seem to be able to replicate it.

    First of all, you'll need to locate a page that causes this error to occur (a page/post containing g+)

    Could you please deactivate ALL other plugins and use the twentytwelve theme?
    This will at least verify if it's a conflict with another plugin or theme...

    Cheers,
    Ari.

  5. gothickmatt
    Member
    Posted 1 year ago #

    Hi Ari,

    Sorry, I think that probably is going to be too much trouble for me. If I could reproduce it on my local test site, it wouldn't be so much of a problem, but I can't, by the looks of it.

    I was mostly just using the plugin to add a +1 button to my posts, so I think I'll just code that into my theme myself and turn off the plugin. Thanks for the quick response and the offer of help, though.

    Regards,

    Matt

  6. That would also work.. :)
    I'm sorry I could not help you on this one any further but you're the only one that has reported an issue like that and we needed to pinpoint its cause in order to figure out a solution.

    Take care,
    Ari.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic