WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] "Registration has been disabled." login error. (11 posts)

  1. mdpdance
    Member
    Posted 1 year ago #

    Hello, first post here. I am glad to see this is a very active community and hope to get this issue resolved.

    First, I would like to say I have followed through this PDF: http://wpebooks.com/wp-content/uploads/downloads/2011/08/CreateAWordPressNetwork.pdf

    I complete every task until I come to the Login again section. I attempt to login which directs me to a page with my theme (I use Gleam theme from Elegant Themes) with the words "Registration has been disabled."

    Note: My Gleam theme's coding also looks a bit broken as well when I surf through the site pages.

    Am I missing anything important? Do I have to upgrade my hosting (hosting info below)?
    I have attempted the following fixes (with no success):
    1. .htaccess and Mod Rewrite & the Switching network types - http://codex.wordpress.org/Multisite_Network_Administration#Network_Admin_Link_Location

    2. I've taken out the "www" in the wp-config.php file with a blank theme'd page.

    Currently, I have put everything back to normal on the back end.

    Specs info:
    I have a GoDaddy domain account with "A @ 50.63.214.131" set in the domain control panel.
    GoDaddy hosting plan with "Hosting - Web - Deluxe - Linux" package.
    I use FileZilla to edit my FTP files.

  2. To fix the problem with registration, go to your Network Admin > Settings and select the appropriate option in "Allow new registrations".

  3. mdpdance
    Member
    Posted 1 year ago #

    Pippin: I cannot get into the Network Admin > Settings area to do this. Once I activate (install) the WordPress Network and attempt to Login, I get a blank page with "Registration has been disabled" message.

  4. Can you get to the Network Admin at all?

  5. mdpdance
    Member
    Posted 1 year ago #

    Only if I revert my .htaccess and wp-config files to what they were before.

    I'm hunting online and learning that the problem may rely inside my .htaccess coding.

    Currently the code in my ".htaccess" is:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteCond %{HTTP_HOST} ^mdpdance.com$ [NC]
    RewriteRule ^(.*)$ http://www.mdpdance.com/$1 [R=301,L]
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*) $1 [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]
    </IfModule>
    
    # END WordPress

    I've added these lines:

    RewriteCond %{HTTP_HOST} ^mdpdance.com$ [NC]
    RewriteRule ^(.*)$ http://www.mdpdance.com/$1 [R=301,L]

    I added them because of this: http://wordpress.stackexchange.com/questions/14383/multisite-non-www-domain-redirects-to-sign-up

    But still no go.

  6. Did you setup the network install manually or with a plugin, such as Enable Multisite?

  7. mdpdance
    Member
    Posted 1 year ago #

    I setup manually. I am using FileZilla to edit and upload my files.

  8. Going to this page triggers "User registration is not enabled"? /wp-admin/network/settings.php

  9. Having www in your domain name has always been squidgy with WP and especially with Mulltisite.

    If this is a brand new install, I would clean it out and start over, this time as domain.com, NO www. If its not new, I would delete the multisite stuff, change it to domain.com, and start over.

    It's just less of a headache.

  10. mdpdance
    Member
    Posted 1 year ago #

    Thank you Ipstenu.
    This resolved my problems. I can now edit multi sites by doing what you said.

    And thank you Pippin for trying to help.

  11. saintephanie
    Member
    Posted 11 months ago #

    I too am facing the same issue as mdpdance. Ipstenu, how do I change my domain to domain.com from http://www.domain.com?

Topic Closed

This topic has been closed to new replies.

About this Topic