WordPress.org

Ready to get started?Download WordPress

Forums

Registration Email Garbled (6 posts)

  1. jlehrhoff
    Member
    Posted 6 years ago #

    I did a plain vanilla install on IIS 6 using PHP 5 and MySQL 4. Also forcing SSL on the site.

    Everything seemed to work fine, but when test-registering a user, the email to the use had some variation of this in the body:
    VXNlcm5hbWU6IGpsZWhyaG9mZgpQYXNzd29yZDogUW9HdVQwNQpodHRwOi8vcHVibGljLmhlYWx0
    aGNhcmVjaGFwbGFpbmN5Lm9yZy93cHRlc3Qvd3AtbG9naW4ucGhwCg==

    Also, I would like to change the "From" email address to the root level domain, not @subdomain.dom.org where the app was installed. Any help would be greatly appreciated.

    Thanks in advance,

    -Jason

  2. haochi
    Member
    Posted 6 years ago #

    Did you edited the wp_new_user_notification() (or wp_mail()) function? It shouldn't base64 the login URL. It's most likely that you have edited something because only the login URL is base64 whereas the rest of the email is in plain text.

    To your second question, yes you can. Just add mail header for the wp_mail function in wp_new_user_notificatoin().

  3. hakre
    Member
    Posted 6 years ago #

    Sent email should be admin email. You can change it in the settings. That is the email that your setup script asked for.

    The text-data you talk about in the mailbody looks like a mime encoding. I have no Idea why the hell this is happening. Maybe IIS6 is not the best choice to host a PHP site.

  4. jlehrhoff
    Member
    Posted 6 years ago #

    the "from" email is not the one I specified.

    I installed the site in subdomain.domain.org and the from email address is just using that domain instead. The settings specify user@domain.org but that is not what is happening.

    Is SSL supported for wordpress? maybe that is why this is happening.

  5. jlehrhoff
    Member
    Posted 6 years ago #

    well I had FastCGI installed and switching to it solved the garbled text issue. I also was able to use the "new user email" plugin to fix the from email address.

  6. hakre
    Member
    Posted 6 years ago #

    Nice to hear things were solved finally. Maybe the FastCGI PHP binary ships with the needed SSL configuration. Can you mark this forum thread as resolved? That would be great!

Topic Closed

This topic has been closed to new replies.

About this Topic