WordPress.org

Ready to get started?Download WordPress

Forums

Registered Only Plugin : Restrict entire blog to r (43 posts)

  1. carthik
    Member
    Posted 9 years ago #

    I was gonna call this plugin "Bouncer" but settled for a more explanatory name instead.
    This plugin will allow only registered users of your blog to view the blog. If you have a wordpress powered blog that you don't want your parents, or the secretary in your office, or the POTUS, to read it(okay, well, I can't guarantee the last one :P), then View source and save or Download the .zip file to start using it. This will effectively password protect your wordpress blog, and also prevent search engines from indexing the pages in the blog.
    Instructions :

    1. Save the file registered_only.php to your wp-content/plugins folder
    2. Activate the plugin from the plugin administration page
    3. Relax

    Usage Notes:

    1. If you really want your defense against unscrupulous readers to be strong, then disable the "Anyone can register" option in Options->General in your WordPress administration interface.
    2. If you want google and other search engines to be able to index your blog pages, then comment(add two // in the beginning of) the line
      echo '<meta name="robots" content="noindex,follow" />'; . This, however, would mean that the search engines might index your pages and if you want a "private" blog, then this would not be suitable, which is why is it uncommented by default.

    This plugin is basically the auth.php file that ships with WordPress 1.2, adapted to fit needs, and is distributed under the GPL license.
    The Viewlevel plugin might interest some folks. That requires you to add some custom text (something like vl="x") to the posts to restrict viewership. Registered only, on the other hand allows only registered users to view the blog, all of it.

  2. Anonymous
    Unregistered
    Posted 9 years ago #

    Is there something similar which just prevents non-registered users from POSTING? I don't mind people reading, but I'd like to restrict posts to only my users...

  3. lawtai
    Member
    Posted 9 years ago #

    why don't you just change the admin level required for users to post?

  4. carthik
    Member
    Posted 9 years ago #

    Anonymous, non registered users cannot access the admin pages, and so cannot post, by default.
    Even newly created users have a user level 0 which allows them to read, but not post.

  5. cyron
    Member
    Posted 9 years ago #

    "why don't you just change the admin level required for users to post?"
    Care to give me some idea how to do that? That would solve the problem I'm having.

  6. ryoken
    Member
    Posted 9 years ago #

    is that with wp 1.3 or 1.2? I've gotten that error with some plug-ins together with 1.3...
    no clue how to solve it though

  7. lazymonster
    Member
    Posted 9 years ago #

    i'm using 1.2, i didn't have other plug-ins activated too
    they seemed to be referring to this method called "header"
    one that goes header(something)
    i don't know php though, any one able to help me with it?
    i notice it only happened when i am not logged in

  8. lazymonster
    Member
    Posted 9 years ago #

    thanks, i'll try that :)

  9. Anonymous
    Unregistered
    Posted 9 years ago #

    Thanks for this plugin, it works well and does what I want it to do except for one small niggle.
    I use Feedreader to read the blog (it's a multi-user blog). The posts are coming through the rss feed fine, I added my username and password to the feed and everything runs OK.
    But .... the comments feed is not feeding. I set it up in the same way as the main feed, with username and password. It doesn't fall over when it checks the blog but it passes nothing back.
    It will be a busy blog and it is already difficult to keep a track of all the comments posted - I *need* my feed!
    Any ideas?
    Thanks
    Beth

  10. trench
    Member
    Posted 9 years ago #

    I installed this on a test blog and was still able to see everything even when logged out. I'm running WP 1.2.1

  11. Anonymous
    Unregistered
    Posted 9 years ago #

    How does this plugin affect the RSS feeds? I want the entire blog to be private, for registered users only, and I don't want anyone to be able to read the posts through the RSS feeds. Should I disable the RSS feeds entirely? How do I do that?

  12. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Delete the atom, rss, rss2 files.

  13. bjcameron
    Member
    Posted 9 years ago #

    I am having the same problem as Trench. I am using 1.2.2 on an IIS sever, MySQL 4.0.13, PHP 4.3.7. All non registered users can view the entire blog.

    Ideas?

    Thanks.

  14. Hathor
    Member
    Posted 9 years ago #

    Hi, I use WP 1.2.2 and after activating the plugin I get the error message

    Warning: Cannot modify header information - headers already sent by (output started at /myserverpath/wordpress/index.php:9) in /myserverpath/wordpress/wp-content/plugins/registered_only.php on line 63
    (and line 64, 65, 66 and 72)

    I did not change the registered_only.php at all.
    Does anyone know what's wrong?

  15. mcdanielscott
    Member
    Posted 9 years ago #

    I am having the exact same issue as Hathor. I use WP on IIS with Win2k, and wp 1.2.2. The weird thing is I am using this plug on the same server with a different wp install in its own mysql db. The actual error is blow.

    Warning: Cannot modify header information - headers already sent by (output started at E:\facilis\is\index.php:9) in E:\facilis\is\wp-content\plugins\registered_only.php on line 63

    Warning: Cannot modify header information - headers already sent by (output started at E:\facilis\is\index.php:9) in E:\facilis\is\wp-content\plugins\registered_only.php on line 64

    Warning: Cannot modify header information - headers already sent by (output started at E:\facilis\is\index.php:9) in E:\facilis\is\wp-content\plugins\registered_only.php on line 65

    Warning: Cannot modify header information - headers already sent by (output started at E:\facilis\is\index.php:9) in E:\facilis\is\wp-content\plugins\registered_only.php on line 66

    Warning: Cannot modify header information - headers already sent by (output started at E:\facilis\is\index.php:9) in E:\facilis\is\wp-content\plugins\registered_only.php on line 72

    Ideas anyone?

  16. starritt
    Member
    Posted 9 years ago #

    Delete all leading and trailing spaces and carriage returns from the top and bottom of the plug in file if they are in there.

  17. tashagirl
    Member
    Posted 9 years ago #

    I am having the same problems as Trench as well. I have the plugin installed and activated but my blog is still viewable to everyone. Help??

  18. James
    Happiness Engineer
    Posted 9 years ago #

    This is obsolete in WP v1.5. Upgrade to WP v1.5, then go Options/General, and under "Membership:" select "Users must be registered and logged in to comment".

  19. Michael Adams (mdawaffe)
    Member
    Posted 9 years ago #

    macmanx: Unless I'm mistaken, that setting only changes who can comment, not who can view.

    tashagirl, trench: no clue. Never used the plugin. Clear cookies/cache after logging out?

  20. tashagirl
    Member
    Posted 9 years ago #

    cleared the cookies and the cache....I don't get it...I used the newest version of the plugin. :::sigh:::

  21. James
    Happiness Engineer
    Posted 9 years ago #

    My apologies, I was made a bad assumption based on the topic title.

  22. hanswu23
    Member
    Posted 9 years ago #

    Had the same "header already sent problem". Switched to the classic theme and all worked fine.

  23. hanswu23
    Member
    Posted 9 years ago #

    Belay my last post. A shameful and regrettable lie.

  24. hanswu23
    Member
    Posted 9 years ago #

    Seems the solution is posted here:

    http://blog.carthik.net/vault/2004/07/04/plugin-registered-users-only/

    If you are getting a “headers already sent� warning, then try adding the following one line to your .htaccess file (create a file called .htaccess if you don’t have one already) :
    PHP_FLAG output_buffering on

  25. davidfraser
    Member
    Posted 9 years ago #

    I have a patch that makes this work with WordPress 1.5, I'm not a PHP coder so it would need to be adjusted as it assumes the directory is /blogs/ (needs this to exclude the login URI)
    It's at http://dev.wp-plugins.org/ticket/134

  26. RobertDeng
    Member
    Posted 9 years ago #

    Yes, I download the patch, but as a layman as I am, I don't know what to do with it. Do I need to upload the patch to the plugin folder. Do I need to modify anything in the patch with my database info? Thank you for the help.

  27. dazmcg
    Member
    Posted 8 years ago #

    You run the patch by copying the patch file to the /plugins directory then running (from linux):

    patch -p0 < filename.patch

    where filename.patch is the patch's file name...

    My question is, how can I get the wp-register.php file to work since I want to allow people to register still if they cannot log in.

    Ta

  28. Trent Adams
    Member
    Posted 8 years ago #

    Please also refer to this post...which the patched file is giving me problems.

    http://wordpress.org/support/topic/29966#post-184703

  29. keaven
    Member
    Posted 8 years ago #

    [blockquote]
    patch -p0 < filename.patch
    [/blockquote]

    what if you do not have shell access to your account? :(

  30. Trent Adams
    Member
    Posted 8 years ago #

    I don't get the content when I am logged in, just a blank page. When I am not logged in, I am redirected to the login page....any idea? This is using the patched version of the plugin.

    Trent

Topic Closed

This topic has been closed to new replies.

About this Topic