WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
[resolved] register_http_request_failed (SSL CA Cert) (7 posts)

  1. deankramer99
    Member
    Posted 1 year ago #

    Hi, after updating my WordPress (3.5.1) and Jetpack (2.1.1) to the most current I now get this error when I try to connect to wordpress.com:

    Jetpack could not contact WordPress.com: register_http_request_failed. This usually means something is incorrectly configured on your web host. Problem with the SSL CA cert (path? access rights?)

    Any ideas?

    http://wordpress.org/extend/plugins/jetpack/

  2. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Can you please try installing the Jetpack Compatibility Plugin so we can see some additional information from your site?

    1) Download the plugin from http://plugins.svn.wordpress.org/jetpack/branches/jetpack-compatibility-test.zip
    2) Upload the plugin to your site via Dashboard -> Plugins -> Add New.
    3) Activate the plugin and go to Plugins -> Jetpack Compatibility Test.
    4) Click the "Select All" button.
    5) Send us the results of the test via this form:
    http://en.support.wordpress.com/contact/?jetpack=needs-service

    Thanks!

  3. deankramer99
    Member
    Posted 1 year ago #

    Hi, I have followed your advice, though I will post the test results here also:

    TEST: Integer Tests
    Array
    (
    [$value = "d0000000";] => (string) d0000000
    [$value = hexdec( $value );] => (integer) 3489660928
    [$value = abs( $value );] => (integer) 3489660928
    [$min = 0;] => (integer) 0
    [$max = 61;] => (integer) 61
    [4294967295 + 1] => (integer) 4294967296
    [$value / (4294967295 + 1)] => (double) 0.8125
    [$max - $min + 1] => (integer) 62
    [($max - $min + 1) * ($value / (4294967295 + 1))] => (double) 50.375
    [$out = $min + (($max - $min + 1) * ($value / (4294967295 + 1)));] => (double) 50.375
    [$out = intval( $out );] => (integer) 50
    [$out = abs( $out );] => (integer) 50
    )

    TEST: wp_generate_password()
    Array
    (
    [0] => 1 -> 1:6
    [1] => 5 -> 5:2Pa3a
    [2] => 10 -> 10:qFoSUjWTRH
    [3] => 16 -> 16:AWx4eqPOThk00wrZ
    [4] => 32 -> 32:pseN7ETmZSXwSicTNYdPBPVzuetzwtrB
    [5] => 32 -> 32:46Kmoz5h51oC4gG6F3y3pLIKToPgR2oZ
    [random_password] => abcdefghijklmnopqrstuvwxyzABCDEFGHIJKLMNOPQRSTUVWXYZ0123456789
    [steps] => Array
    (
    [0] => 26 -> A
    [1] => 34 -> I
    [2] => 46 -> U
    [3] => 49 -> X
    [4] => 57 -> 5
    [5] => 8 -> i
    [6] => 19 -> t
    [7] => 43 -> R
    [8] => 9 -> j
    [9] => 25 -> z
    [10] => 35 -> J
    [11] => 19 -> t
    [12] => 41 -> P
    [13] => 39 -> N
    [14] => 19 -> t
    [15] => 39 -> N
    [16] => 19 -> t
    [17] => 30 -> E
    [18] => 20 -> u
    [19] => 51 -> Z
    [20] => 35 -> J
    [21] => 27 -> B
    [22] => 1 -> b
    [23] => 57 -> 5
    [24] => 40 -> O
    [25] => 3 -> d
    [26] => 2 -> c
    [27] => 47 -> V
    [28] => 19 -> t
    [29] => 22 -> w
    [30] => 39 -> N
    [31] => 54 -> 2
    )

    [ReflectionFunction] =>
    /**
    * Generates a random password drawn from the defined set of characters.
    *
    * @since 2.5
    *
    * @param int $length The length of password to generate
    * @param bool $special_chars Whether to include standard special characters. Default true.
    * @param bool $extra_special_chars Whether to include other special characters. Used when
    * generating secret keys and salts. Default false.
    * @return string The random password
    **/
    Function [ <user> function wp_generate_password ] {
    @@ /home/dean/public_html/wp-includes/pluggable.php 1485 - 1499

    - Parameters [3] {
    Parameter #0 [ <optional> $length = 12 ]
    Parameter #1 [ <optional> $special_chars = true ]
    Parameter #2 [ <optional> $extra_special_chars = false ]
    }
    }

    )

    TEST: wp_rand()
    Array
    (
    [0] => '2f9bbe2c60a9df165eb3b40c79c3753b60be857763d14261d4570430c1d1129d21e0098b7700838265c9a5eb69a94049'
    [1] => 11:94049a96be5a9c5628380077b8900e12d9211d1c0340754d16241d367758eb06b3573c97c04b3be561fd9a06
    [2] => 23:94049a96be5a9c5628380077b8900e12d9211d1c0340754d16241d367758eb06b3573c97c04b3be5
    [3] => 22:94049a96be5a9c5628380077b8900e12d9211d1c0340754d16241d367758eb06b3573c97
    [4] => 29:94049a96be5a9c5628380077b8900e12d9211d1c0340754d16241d367758eb06
    [5] => 23:94049a96be5a9c5628380077b8900e12d9211d1c0340754d16241d36
    [6] => 24:94049a96be5a9c5628380077b8900e12d9211d1c0340754d
    [7] => 51:94049a96be5a9c5628380077b8900e12d9211d1c
    [8] => 46:94049a96be5a9c5628380077b8900e12
    [9] => 8:94049a96be5a9c5628380077
    [10] => 28:94049a96be5a9c56
    [11] => 24:94049a96
    [12] => 25:
    [13] => 61:fedcefa1465bccce00842f80235c8ba0c36325965494eb700ae59cf5bcbc25bbba7cfaffa1c2949817f4276061c81f4aa0a40679
    [14] => 36:fedcefa1465bccce00842f80235c8ba0c36325965494eb700ae59cf5bcbc25bbba7cfaffa1c2949817f4276061c81f4a
    [15] => 39:fedcefa1465bccce00842f80235c8ba0c36325965494eb700ae59cf5bcbc25bbba7cfaffa1c2949817f42760
    [16] => 1:fedcefa1465bccce00842f80235c8ba0c36325965494eb700ae59cf5bcbc25bbba7cfaffa1c29498
    [17] => 33:fedcefa1465bccce00842f80235c8ba0c36325965494eb700ae59cf5bcbc25bbba7cfaff
    [18] => 61:fedcefa1465bccce00842f80235c8ba0c36325965494eb700ae59cf5bcbc25bb
    [19] => 45:fedcefa1465bccce00842f80235c8ba0c36325965494eb700ae59cf5
    [20] => 23:fedcefa1465bccce00842f80235c8ba0c36325965494eb70
    [MIN] => 1
    [MAX] => 61
    [ReflectionFunction] =>
    /**
    * Generates a random number
    *
    * @since 2.6.2
    *
    * @param int $min Lower limit for the generated number
    * @param int $max Upper limit for the generated number
    * @return int A random number between min and max
    */
    Function [ <user> function wp_rand ] {
    @@ /home/dean/public_html/wp-includes/pluggable.php 1512 - 1546

    - Parameters [2] {
    Parameter #0 [ <optional> $min = 0 ]
    Parameter #1 [ <optional> $max = 0 ]
    }
    }

    )

    TEST: HTTP Connection
    Array
    (
    [headers] => Array
    (
    [server] => nginx
    [date] => Mon, 28 Jan 2013 20:08:05 GMT
    [content-type] => text/plain;charset=utf-8
    [connection] => close
    [vary] => Cookie
    [x-pingback] => http://jetpack.wordpress.com/xmlrpc.php
    [expires] => Wed, 11 Jan 1984 05:00:00 GMT
    [cache-control] => no-cache, must-revalidate, max-age=60
    [pragma] => no-cache
    [x-hacker] => Jetpack Test
    )

    [body] => OK
    [response] => Array
    (
    [code] => 200
    [message] => OK
    )

    [cookies] => Array
    (
    )

    [filename] =>
    )

    TEST: HTTPS Connection
    WP_Error Object
    (
    [errors] => Array
    (
    [http_request_failed] => Array
    (
    [0] => Problem with the SSL CA cert (path? access rights?)
    )

    )

    [error_data] => Array
    (
    )

    )

    TEST: Self Connection
    Array
    (
    [headers] => Array
    (
    [date] => Mon, 28 Jan 2013 20:08:06 GMT
    [server] => Apache/2.2.22 (Fedora)
    [x-powered-by] => PHP/5.3.20
    [content-length] => 42
    [connection] => close
    [content-type] => text/plain; charset=UTF-8
    )

    [body] => XML-RPC server accepts POST requests only.
    [response] => Array
    (
    [code] => 200
    [message] => OK
    )

    [cookies] => Array
    (
    )

    [filename] =>
    )

  4. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Thanks.

    It seems that your server cannot make verified outgoing HTTPS requests to https://jetpack.wordpress.com/

    It could be caused by some configuration issues with your server's SSL certificate. Could you contact your hosting provider, and ask them to have a look?

  5. deankramer99
    Member
    Posted 1 year ago #

    I do my own hosting. It just seems strange as it was working before the update, unless this issue is a fairly new feature that wasn't in the version I had?

    I do though only have self-signed certificates (if you https my blog), could that be an issue? Its strange as I can https my blog and the correct certificate information comes up in the browser.

    I just rebooted my server and tried again and got this:
    Error Details: The Jetpack server was unable to communicate with your site [IXR -32300: transport error: http_request_failed SSL certificate problem: self signed certificate]

    Should I assume that self-signed certificates are now a problem, as it was working, and I have always used self-signed certificates.

  6. deankramer99
    Member
    Posted 1 year ago #

    Right, it appears that to be able to setup jetpack I have to do it in HTTP not HTTPS, but once setup, I can use my blog in HTTPS and the plugin appears to work.

    How will this affect the plugin? Will the connection only be HTTP though the blog will be in HTTPS?

  7. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Thanks for the extra details. I don't know your site URL, so I couldn't check how HTTPS was set up on your site.

    Jetpack is currently not setup to work with sites that are only accessible over HTTPS using a self-signed certificate.

    We have plans to make that work better in the future, but I am not sure how long it will be before the Jetpack team can get to an update like that.

    I'm sorry for the inconvenience.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.