WordPress.org

Ready to get started?Download WordPress

Forums

Register Plus is adding "\"'s to all quote marks in Registration Email (8 posts)

  1. alexwoolfson
    Member
    Posted 5 years ago #

    Hello,

    Very nice plugin. I customized the Registration email that my users will get. Everything seems to work O.K. except that it is adding "\"s to every single and double quote in the email.

    Can this be fixed?

    Thank you very much for your excellent plugin.

    Alex

  2. skullbit
    Member
    Posted 5 years ago #

    Will get this fixed soon for you, been busy lately!

  3. alexwoolfson
    Member
    Posted 5 years ago #

    Awesome. Thank you for the excellent plugin. Look forward to the fix. Will donate. :-D

  4. DanoNH
    Member
    Posted 5 years ago #

    Yes I agree this plugin is excellent and too am looking forward to the fix because I am having the same problem, only here is more detail:

    Under both the "Customize User Notification Email" and "Customize Admin Notification Email" sections, if you enter field text as follows:

    From Name: Dan's Blog
    Subject: [Dan's Blog] Your username and password

    and then save the settings, your fields will be modified to:

    From Name: Dan\'s Blog
    Subject: [Dan\'s Blog] Your username and password

    The next time you save the settings, the fields get modified again to:

    From Name: Dan\\\'s Blog
    Subject: [Dan\\\'s Blog] Your username and password

    This continues until you enter the following:

    From Name: Dan\'s Blog
    Subject: [Dan\'s Blog] Your username and password

    which when saved the first time only will yield the desired results:

    From Name: Dan's Blog
    Subject: [Dan's Blog] Your username and password

    wierd...

    Thanks... Dan

  5. DanoNH
    Member
    Posted 5 years ago #

    Hi Skullbit (and Alexwoolfson)...

    I have fixed this for now. Please update the master plugin code with these changes or similar ones (I am using version 3.5.1 of Register-Plus):

    Just before the <div id="enabled_msg"> on line 863, add the following lines:

    <?php if(get_magic_quotes_gpc())
    {
    $regplus['from'] = stripslashes($regplus['from']);
    $regplus['fromname'] = stripslashes($regplus['fromname']);
    $regplus['subject'] = stripslashes($regplus['subject']);
    }
    ?>

    And before the
    <h3><?php _e('Customize Admin Notification Email', 'regplus');?></h3>
    around line 910 (before the previous modification), add these:

    <?php if(get_magic_quotes_gpc())
    {
    $regplus['adminfrom'] = stripslashes($regplus['adminfrom']);
    $regplus['adminfromname'] = stripslashes($regplus['adminfromname']);
    $regplus['adminsubject'] = stripslashes($regplus['adminsubject']);
    }
    ?>

    This worked well for me; my hosting provider has magic quotes turned on.

    Good luck!
    Dan

  6. DanoNH
    Member
    Posted 5 years ago #

    Hello,

    I found that Register Plus was creating a runtime error at line 95 in IE7 at the register page, and submitting a new user registration caused warnings in wp-includes/pluggable.php and wp-includes/plugin.php.

    I read the conflicts discussion page but I don't use Events Calendar or eShop, Members Only or WP Multiuser.

    I have disabled it now and no more errors with registration page rendering or submission.

    I wish this plugin functioned better because I really like the work that has been done with Register Plus.

    Dan

  7. Dgold
    Member
    Posted 5 years ago #

    Hmmm makes me think I need to double-check if it's operating properly on the site I use this plugin on. I mean, it works, some people have registered, but now I'm wondering if it works the same in all browsers.

  8. DanoNH
    Member
    Posted 5 years ago #

    @ Dgold:

    I actually like this plugin and since my last post here I have modified the plugin file to fix the browser errors. I have determined these were not caused by any conflict with another plugin. My solution for now so I may continue to use it are the below modifications (should suit you as well), as well as simply making sure to not use any single or double quotation marks in any of the custom user email or custom admin email fields in the plugin config:

    Modification: add single quotes as shown below to 2 lines of code:

    Around line 1400, in register-plus.php, change

    jQuery(function() {
      jQuery('.date-pick').datePicker({
      clickInput:true,
      startDate:'<?php echo $regplus['startdate'];?>',
      year:<?php echo $regplus['calyear'];?>,
      month:<?php if( $regplus['calmonth'] != 'cur' ) echo $regplus['calmonth']; else echo date('n')-1;?>
    	})
    });

    to

    jQuery(function() {
      jQuery('.date-pick').datePicker({
      clickInput:true,
      startDate:'<?php echo $regplus['startdate'];?>',
      year:'<?php echo $regplus['calyear'];?>',
      month:'<?php if( $regplus['calmonth'] != 'cur' ) echo $regplus['calmonth']; else echo date('n')-1;?>'
    	})
    });

    (note the single-quotes around the year and month php statements)

    I am confident if I spent enough time on this I could fix the wierd quotation behavior; the changes I previously posted above still apply but somehow didn't fix the Custom User Email "from" name or the Custom Admin Email "from" name either.

    Although the plugin author has responded here over a month ago, there is another site with more recent comments about register-plus: here. IMHO, since this is being officially offered through the WordPress site, the support page here should be more actively used.

    Great idea, very useful plugin... if I have some free time (never do), I will try to fix the plugin file to allow single and double quotes and post my findings here.

    Dan

Topic Closed

This topic has been closed to new replies.

About this Topic