WordPress.org

Ready to get started?Download WordPress

Forums

Register Plus email verification link redirects to front page (9 posts)

  1. at133
    Member
    Posted 5 years ago #

    I have set up Register Plus 3.5.1 on WordPress 2.7 and turned on email verification. The email is sent fine, but clicking the link in the email just takes you to the front page of the site and doesn't activate the account. I have tried it on a brand new setup with the same results.

  2. MichaelH
    Member
    Posted 5 years ago #

    Just activated Register Plus and was not able to duplicate your problem. I was directed to the login screen with this message being displayed on the login screen:
    "Thank you MichaelH, your account has been verified, please login."

    The link in the email was like this:

    http://www.sample.com/blog/wp-login.php?regplus_verification=35682956249ia45akm96gib20i&redirect_to=http://www.sample.com/blog

  3. at133
    Member
    Posted 5 years ago #

    I just installed another instance of wordpress and tried it again, but it still didn't work. My url is formatted the same as yours, but when I click it it takes me to http://www.sample.com/blog/wp-login.php/?regplus_verification=35682956249ia45akm96gib20i&redirect_to=http://www.sample.com/blog (Note the front slash after wp-login.php) instead. Could this be the problem?

  4. at133
    Member
    Posted 5 years ago #

    I believe that the problem is that it is not escaping the redirect url. If I remove the url from the string then it works. Is there a way to tell wordpress to accept unescaped urls, because the url you posted was not escaped.

  5. eLiasPT
    Member
    Posted 5 years ago #

    Any news on how to solve this problem? Getting this problem on my 3 websites.
    Thank you.

  6. superann
    Member
    Posted 5 years ago #

    Your host probably doesn't like the improperly encoded redirect_to variable.

    If you manually remove the redirect_to query var from the url (so just input http://www.sample.com/blog/wp-login.php?regplus_verification=35682956249ia45akm96gib20i), and it DOES work, then this should be the reason for the problem you're experiencing.

    To fix, search for this line in the file register-plus.php (should be line 1905 or around there):

    $redirect = 'redirect_to=' . $regplus['login_redirect'];

    Replace it with:

    $redirect = 'redirect_to=' . urlencode($regplus['login_redirect']);
  7. richcon
    Member
    Posted 5 years ago #

    There's also a conflict with the Customize Your Community plugin, which rewrites your login form but fails to call the necessary hook used by this plugin. This can be easily fixed by editing the CYC plugin's cyc.php file to change:

    <label for="user_pass"><?php _e('Password:') ?></label>
    <input name="pwd" class="mid" id="user_pass" type="password" />
    <input name="rememberme" class="checkbox" id="rememberme" value="forever" type="checkbox" checked="checked"/>
    <label for="rememberme"><?php _e('Remember me'); ?></label>

    to:

    <label for="user_pass"><?php _e('Password:') ?></label>
    <input name="pwd" class="mid" id="user_pass" type="password" />
    <?php do_action('login_form'); ?>
    <input name="rememberme" class="checkbox" id="rememberme" value="forever" type="checkbox" checked="checked"/>
    <label for="rememberme"><?php _e('Remember me'); ?></label>
  8. reviewabc
    Member
    Posted 5 years ago #

    Hi Richcon,

    It works.. thanks you for your tricks. :)

  9. mores
    Member
    Posted 4 years ago #

    @richcon ... thank you so much for this bit of info. I was already throwing a fit since my client wanted double opt-in and I couldn't give it to him.

    Anyhow ... now on to getting the layout just right. And figure out why the password field is at the bottom of the form. Ruins my layout!

Topic Closed

This topic has been closed to new replies.

About this Topic