WordPress.org

Ready to get started?Download WordPress

Forums

register accounts email not sending (6 posts)

  1. fatalcure
    Member
    Posted 9 years ago #

    When new users register accounts, they don't get an email. What do I need to do to fix this? <-- I did a search and this guy and other have the same problem as me... yet there are no responses...

    Im running wordpress on windows xp, apache 2.0.. do i need to install a mail server or something aswell or is it something i need to edit in the wordpress files...

    any help would be greatly appreciated

  2. egeyisi
    Member
    Posted 9 years ago #

    Me too, I have exactly the same problem! First I thought iy may be because of I changed the template of wp-register.php. So I tried it again by the default template. But it didn't work.

    Is there anyone who has a solution?

  3. dannyhec
    Member
    Posted 9 years ago #

    I'm having the same problem also, all other e-mails send just fine, password resets and all the administrative alerts come in just fine. I thought it might have been junk mail filter blocking the messages but it's not, I received messages for password resets to Hotmail, Gmail, and Yahoo.

    Any ideas what it might be? Thanks for all the help!

  4. pidus
    Member
    Posted 9 years ago #

    This problem is caused by SAFE_MODE turned on on your server. In SAFE_MODE funcion 'mail()' can have only 4 arguments and in functions.php there is this function called with 5 args.

    All you have to do to fix this problem is to edit ./wp-includes/functions.php and change the line #1604 from

    return @mail($to, $subject, $message, $headers, $more);

    to

    return @mail($to, $subject, $message, $headers);

  5. fatalcure
    Member
    Posted 9 years ago #

    ok i did it and i tried registering.. so far ive recieved no email.. lets hope its just being slow

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags