WordPress.org

Ready to get started?Download WordPress

Forums

Reg Level Plugin : Not Working with 2.7 (6 posts)

  1. mfshearer72
    Member
    Posted 5 years ago #

    Get this error:

    Warning: Cannot modify header information - headers already sent by (output started at /home/.chad/mshearer/www.netexperienced.com/cms/wp-content/themes/plainscape.1.0/plainscape/page.php:10) in /home/.chad/mshearer/www.netexperienced.com/cms/wp-includes/pluggable.php on line 850

    I disable the Reg Level Plugin and this error disappears. I tried Reg Level on a different site and got a similar error (different location in the code, however).

    I tried going into the plugin to look for whitespaces, as well as the place in the code highlighted by the warning, but no luck.

    Any thoughts?

  2. Eric Mann
    Member
    Posted 5 years ago #

    Sorry for taking so long to get on this. The original code used the wp_redirect() function to send people to the appropriate registration page. Unfortunately, this breaks on many themes and on WP 2.7 in particular.

    I am still planning a fully-featured new release sometime soon (including upgraded features, admin menus, and a built-in user permissions manager), but since I can't set a specific date I've created a temporary "fix" for the plugin. In situations where headers have already been sent (the error above), the plugin instead feeds a meta redirect to the page. This isn't the best way to do things ... but it will work for now and will give me time to finish polishing off version 1.0 of the plugin.

    Enjoy, and let me know if you run into any more problems!

  3. Eric Mann
    Member
    Posted 5 years ago #

    mfshearer72 - The newest version of the plug-in is now available from the WordPress repository. It no longer uses the wp_redirect() function or the hacked together meta refresh I had set up for the temporary fix. The new version (1.0) uses a completely different - and safe - method for redirection and setting user roles.

  4. starapple
    Member
    Posted 5 years ago #

    I've just installed the upgrade to use with WP 2.71. I get a blank screen when I visit the link http://www.abengnews.com/?reglevel=intern

    Am not sure whether it's the fault of the template but I doubt this since the registration page comes up on my local test http://marklee.dyndns.org/wordpress/?reglevel=contributor

  5. starapple
    Member
    Posted 5 years ago #

    Scrap that previous post. Plugin works perfectly. It just doesn't know that I'm using a static homepage in the root directory. It probably needs a little bit of code to figure that out.

    Thanks ericmann for reading my mind so well in advance and making what is now for me a necessary plugin.

  6. Eric Mann
    Member
    Posted 5 years ago #

    @starapple Any time! :-)

Topic Closed

This topic has been closed to new replies.

About this Topic