WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Redirects to main admin site from my beta subdomain (2 posts)

  1. tyr
    Member
    Posted 8 years ago #

    I decided I wanted to do a redesign of my blog and so I took the following steps to create a "beta" site to play around with.
    1) Export a full SQL database of my existing blog
    2) Import the SQL database into a new database (I have two from my host). I did not change any table names.
    3) Created a subdomain on my site beta.raincityguide.com and uploaded the latest version of WP there along with a few files that I had added (photos and plug-ins).
    4) Changed the name of the database within the wp-config.php file to reflect the new database.
    5) Loaded on the ".../wp-admin/upgrade.php" (completed without errors)

    When I load this beta site, everything is fine except all the blog entries and links point to the non-beta version.

    AND when I try to go to the beta version of ".../wp-admin", it redirects me to the live version. This makes I can't load the new theme I've been working on into beta.

    It seems clear to me that I missed at least one thing in the configuration but despite my searching, I can't seem to find it.

    Now that I've said all this, I should also note that all I want to do is create a beta blog that closely resembles my main blog so that I can minimize errors when I go to push the new design to live. If there is a better way to do this, I'd definitely be interested in hearing about it!

  2. tyr
    Member
    Posted 8 years ago #

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags