WordPress.org

Ready to get started?Download WordPress

Forums

WordPress HTTPS (SSL)
[resolved] redirects to default apache page (17 posts)

  1. motofiller
    Member
    Posted 3 years ago #

    I installed the HTTPS plugin and then on my checkout page selected force ssl. It goes to https but i get the default "it works" page.

    wp ecommerce plugin
    storefrontthemes elegance theme.

    any idea?

  2. SAHIL
    Member
    Posted 3 years ago #

    may be ssl is not set for your virtual host(your domain) so it redirects to default page...
    check the config file and see whether ssl is set for ur domain..

  3. motofiller
    Member
    Posted 3 years ago #

    If i put ssl in my virtual host the entire site changes to ssl (if i remember correctly). I will look again. Seems like it either did that or gave me an error.

  4. SAHIL
    Member
    Posted 3 years ago #

    If i put ssl in my virtual host the entire site changes to ssl

    I didnt understand that.. can u explain in more detail ??

    do u host a site on vps or a dedicated server ??

  5. motofiller
    Member
    Posted 3 years ago #

    My goal is to only have the checkout page https.
    I can't access my server at the moment but i believe if i put the ssl lines in my virtual host config for my site (apache2 ubuntu) then it changes the entire site to https.
    I am running a dedicated server from my hope. All ports that are needed have been forwarded.
    I know that ssl works because phpadmin and sever other GUI's i use are https.

    Hope that explains things better.

  6. SAHIL
    Member
    Posted 3 years ago #

    I know that ssl works because phpadmin and sever other GUI's i use are https.

    If you have control panels like Cpanel, Plesk, Webmin then they run their own webserver and have no relation with apache..

    can u enable ssl and give me link to your site... so dat i can see wat exactly is happening...??

  7. motofiller
    Member
    Posted 3 years ago #

    <quote>If you have control panels like Cpanel, Plesk, Webmin then they run their own webserver and have no relation with apache..</quote>

    Ah that makes sense. It will be later this afternoon say 4:00 cst before i could enable ssl. I wouldn't want to leave it like that for long.

  8. SAHIL
    Member
    Posted 3 years ago #

    It will be later this afternoon say 4:00 cst before i could enable ssl. I wouldn't want to leave it like that for long.

    Can u enable it now.. because i live in India and here it is 9:45 PM
    at 4:00 cst it would be very early in the morning here..(like 3:30 AM)

    well enabling ssl and it being redirected to default page wont cause any security issues.. so post the link and i will see it tommorow ..

  9. motofiller
    Member
    Posted 3 years ago #

    No i cannot sorry. Its not a security issue its a matter of the site not working correctly. Its live. So the best i could do is enable it around 7:00 am CST so around 4:00 PM your time.

  10. SAHIL
    Member
    Posted 3 years ago #

    ok.. then i'll see it tommorow at 4.00 pm..

  11. motofiller
    Member
    Posted 3 years ago #

    Thanks

  12. motofiller
    Member
    Posted 3 years ago #

    I got this to work. Turns out i had put the sslengine on in the wrong place.

    Curious thing though. I have a self signed cert and it doesn't seem to give the untrusted warning in forefox 4. Haven't tested outside of my home yet though.

    http:motofiller.com

  13. SAHIL
    Member
    Posted 3 years ago #

    the site is working fine but dont use a self signed certificate.. it show untrusted warning in every browser...

    ssl certificates of single domain are quite cheap like $10/year..

    also some content from google font api is still being loaded using http ... check that out .. it will still generate warnings even if you buy a ssl certificate..

  14. motofiller
    Member
    Posted 3 years ago #

    Yeah the self signed was just for testing. How do i test that everything is being loaded https instead of some like the google api loading http?

  15. SAHIL
    Member
    Posted 3 years ago #

    you need chrome or firebug extension for firefox..

    open your site using https and press ctrl + shift + c and then console tab
    if you find any script of file starting from http then dats the culprit ...

    you might have to edit the theme and change the scripts to https..
    or just use external https elements option of this plugin

  16. motofiller
    Member
    Posted 3 years ago #

    The google links are in the header, so if i change them won't that make them https for the entire site? Will that matter.

  17. SAHIL
    Member
    Posted 3 years ago #

    no it wont matter.. but first before changing them manually try external https elements option of this plugin

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic