WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Redirection to new domain problem (11 posts)

  1. RLAJay
    Member
    Posted 3 years ago #

    I've spent all day trying to do this and it's been a nightmare.

    I've copied across all the files for http://www.blog.rlaschool.com to my new domain, http://www.reallifeattraction.com using ftp.

    I've set up a new database and ensured wpconfig on the new wordpress points to the new database, I've copied the database from blog.rlaschool.com and put it there. I've been through the database and changed all URLs using a URL change plugin.

    I have set up the .htaccess (now removed because the site is broken) file to 301 redirect to the new domain using the following snippet:

    RewriteRule (.*) http://www.newdomain.com/$1 [R=301,L]

    Placed after RewriteEngine on

    ---

    I thought all of this was working fine. Upon viewing http://www.blog.rlaschool.com I was getting redirected perfectly to the new domain. The problem is that is the ONLY thing that was working, I have just realised that absolutely none of the posts are there in reality when you try to click through to them. Only the homepage works.

    What have I done wrong? I could really use some help with this.

  2. webjunk
    Member
    Posted 3 years ago #

    As the site is not running WordPress not sure what you are trying to do.

  3. RLAJay
    Member
    Posted 3 years ago #

    My apologies.

    http://www.blog.reallifeattraction.com missed out the subdomain.

  4. RLAJay
    Member
    Posted 3 years ago #

    Bump, still having trouble with this.

  5. RLAJay
    Member
    Posted 3 years ago #

    Bump again. Still can't find the problem.

  6. webjunk
    Member
    Posted 3 years ago #

    Kinda looks like you have the URL's set to the old domain in Wp-admin/GENERAL/Settings

    CHeck that first.
    Be aware bumping may actually get you ignored. We are all just volunteers on here and have our own websites to work on.

  7. RLAJay
    Member
    Posted 3 years ago #

    I'll take a look, thanks for the response.

    Not sure what I ought do other than bump to get response. Not bumping after the topic has fallen off the second page guarantees it'll get no response.

    EDIT: That's not it, the site addresses are set to http://www.blog.reallifeattraction.com in general settings. I presume that must have been changed by the plugin I used.

  8. webjunk
    Member
    Posted 3 years ago #

    What is in your .htaccess? (Put into Pastebin if its large)

  9. RLAJay
    Member
    Posted 3 years ago #

    The current htaccess is:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
  10. webjunk
    Member
    Posted 3 years ago #

    Try turning your Permalinks off.

  11. RLAJay
    Member
    Posted 3 years ago #

    Wait a second, I think you may have found the problem for me. It appears I made an error, I had absolutely no htaccess file on the new domain.

    Adding a htaccess appears to have fixed it all, here's hoping it stays that way.

    Marking as resolved, thanks for the help webjunk! You lovely helpful person you.

Topic Closed

This topic has been closed to new replies.

About this Topic