WordPress.org

Ready to get started?Download WordPress

Forums

WordPress HTTPS (SSL)
Redirecting to https when I log out (13 posts)

  1. rubious
    Member
    Posted 1 year ago #

    I have "Force SSL Exclusively" switched on, yet after logging out and being redirected to the homepage I'm redirected to the https version of the homepage (which I do not want). That page is not selected to be SSL.

    http://wordpress.org/extend/plugins/wordpress-https/

  2. Mvied
    Member
    Plugin Author

    Posted 1 year ago #

    If you have Force SSL Exclusively on and you're not securing the homepage, it should be impossible to hit it over HTTPS, regardless of how you got there. So either something isn't working, there's an issue with your server configuration, or your home page is secured for some reason.

  3. rubious
    Member
    Posted 1 year ago #

    I'm using CloudFlare Flexible SSL if that makes any difference?

  4. Mvied
    Member
    Plugin Author

    Posted 1 year ago #

    Maybe. I've used it fine before.

    You described a very particular scenario. Have you tried just enabling Force SSL Exclusively and hitting any page that shouldn't be secure? They should always redirect to HTTP.

  5. rubious
    Member
    Posted 1 year ago #

    I just tried that, it seems the Force SSL is not working at all, pages are not redirecting to the non-SSL page.

  6. Mvied
    Member
    Plugin Author

    Posted 1 year ago #

    Then it's likely the issue is CloudFlare. Enable Debug Mode and look for an entry in the debug output that says "SSL: Yes/No". If you don't know where to find it, let me know.

  7. rubious
    Member
    Posted 1 year ago #

    I'm trying to switch debug mode on but when I tick the box and press save there is an error:

    POST https://www....co.uk/wp-admin/admin.php?page=wordpress-https 500 (OK) load-scripts.php:4
    send load-scripts.php:4
    f.extend.ajax load-scripts.php:4
    b.fn.ajaxSubmit load-scripts.php:35
    ajaxFormUnbind.bind.bind.i load-scripts.php:35
    f.event.dispatch load-scripts.php:3
    h.handle.i

  8. Mvied
    Member
    Plugin Author

    Posted 1 year ago #

    Oh good. Looks like a 500 error. You'll have to check your error logs for the error generated by that URL.

  9. rubious
    Member
    Posted 1 year ago #

    No error logs are showing up for this error. Not sure how I can debug it now?

  10. Mvied
    Member
    Plugin Author

    Posted 1 year ago #

    That sounds like a parse error or a file permissions problem. Check the file permissions for the plugin. Also, check to see what version of PHP you're using.

  11. rubious
    Member
    Posted 1 year ago #

    I have set everything in the plugin folder to CHMOD 755, no change
    I am running PHP version 5.3.5.

    Interestingly I have made a complete copy of the site and deactivated all plugins except HTTPS and it works. I did a process of elimination to find out which plugin was causing problems and it is WooCommerce.

    If WooCommerce is active, this problem happens. If I deactivate it the problem goes away.

    Also, each time I activate or deactivate the WooCommerce plugin it asks me to log in again. Not sure why that is.

    It is WooCommerce Version 1.6.5.2

  12. Mvied
    Member
    Plugin Author

    Posted 1 year ago #

    What works when it's disabled? Force SSL Exclusively, saving the settings or both?

  13. rubious
    Member
    Posted 1 year ago #

    Both.

    I think the Force SSL Exclusively is only not working because I can't change the setting. Is there an entry in the database I can just change to get this working?

    But of course we really need to get the settings page changes working too.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.