WordPress.org

Ready to get started?Download WordPress

Forums

WordPress Social Login
[resolved] Redirecting to homepage after login instead to curl (10 posts)

  1. czarek77
    Member
    Posted 1 year ago #

    Hi, i notice that after last update WPSL on my pages redirect user to homepage instead to post page where user loged in to post a comment. Is there are some bug or only my configuration?
    Regards.

    http://wordpress.org/extend/plugins/wordpress-social-login/

  2. czarek77
    Member
    Posted 1 year ago #

    Please guys can anyone can help me, maybe someone has similar problem. I need to fix that error. As i said, after login on post page (to leave a comment) user are redirect to homepage instead to stay on current post page.
    Regards.

  3. Miled
    Member
    Plugin Author

    Posted 1 year ago #

    try this, and let me know if it doesn't work :
    reinstall wsl, goto Widget>Redirect URL, keep that field empty and then hit save (this should reset to default)

  4. czarek77
    Member
    Posted 1 year ago #

    thanks a lot for this solution, it worked. :)

  5. Skalibur1
    Member
    Posted 1 year ago #

    HI Miled:

    Impossible to erase the redirect URL,,, Is possible change it,, but no erase :(

    I erased the plugin and re install it 2 times, I delete browser cookies,etc.

    :(

  6. Skalibur1
    Member
    Posted 1 year ago #

    Miled: Can you write us a reload or "actual page" link code to put in the "redirect url" form?

    Best Regards for the support

  7. derixc
    Member
    Posted 1 year ago #

    Hi Miled!

    Same issue with Skalibur1. I can't delete the url.

    Tried deactivating and deleting the plugin but no go. Can you guide us through phpmyadmin.

  8. Miled
    Member
    Plugin Author

    Posted 1 year ago #

    Callback url can't be deleted. It can only be rested to default (when Callback field is left empty, WSL will regenerate that url again)

    on another side note, and if I'm not mistaken about Skalibur1 case. The authentication widget was rendered on the login page and not in comments sections, so wsl was working as expected by redirecting users back to homepage.

  9. derixc
    Member
    Posted 1 year ago #

    Hi Miled.

    Got it.

    But how do you go about re-installing the plugin? De-activated, delete, install and activate still has the redirect url.

    "reinstall wsl, goto Widget>Redirect URL, keep that field empty and then hit save (this should reset to default) "

  10. Miled
    Member
    Plugin Author

    Posted 1 year ago #

    I'm not sure to understand your last question.

    the whole point behind asking users to reinstall wsl is to make sure their are using the same version as me so we could all be on the same page, while taking advantage of any new enhancements or bug fixes.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic