WordPress.org

Ready to get started?Download WordPress

Forums

WordPress Social Login
redirect_uri_mismatch for Google Login (9 posts)

  1. Portoa
    Member
    Posted 1 year ago #

    I was testing the login for Google profile & ended up with this error:
    redirect_uri_mismatch

    The redirect URI in the request: http://mysite.com/wp-content/plugins/wordpress-social-login/hybridauth/?hauth.done=Google did not match a registered redirect URI

    http://wordpress.org/extend/plugins/wordpress-social-login/

  2. Stidor
    Member
    Posted 1 year ago #

    I had the same problem. I had to update API settings for Google

    Go to the API Console: https://code.google.com/apis/console/

    In your project, check the API Access settings and make sure that URL is one of the Redirect URIs. If not, add it.

  3. Been Young
    Member
    Posted 12 months ago #

    I have that error too, how to fix it?

  4. grv0077
    Member
    Posted 12 months ago #

    I have resolve this Issue:--

    Go to the API Console: https://code.google.com/apis/console/

    Select the Api Access at the left Panel:-

    After that go to Client ID for web applications and click edit setting in the right side then a popup is open.
    Change the link for Client ID for web applications to http://mysite.com/wp-content/plugins/wordpress-social-login/hybridauth/?hauth.done=Google

    after that save all the changes.

  5. Dennis
    Member
    Posted 9 months ago #

    Thanks its worked fine.

  6. leokfoury
    Member
    Posted 8 months ago #

    Greetings grv0077

    Thanks for your reply - solved!
    success!
    LK

  7. mariz_p
    Member
    Posted 6 months ago #

    I can't change the client id in my google api console. May you please elaborate your instructions more @grv007?

    Thanks.

  8. mariz_p
    Member
    Posted 6 months ago #

    Oh Problem solved!

  9. carolinezambon
    Member
    Posted 1 month ago #

    Will this configuration work for sub-websites? I'm creating a website under my domain and this configuration did not worked. :(

    The error:
    "Error: redirect_uri_mismatch

    The redirect URI in the request: http://www.carolinezambon.com.br/dottf/wp-content/plugins/wordpress-social-login/hybridauth/?hauth.done=Google did not match a registered redirect URI"

    Thank you!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.