WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Redirect on Local Installation after Upgrade to 2.3 (5 posts)

  1. dadthing
    Member
    Posted 6 years ago #

    Hi,

    I am using XAMPP. I copied all of the WordPress 2.3 files to my local machine, imported my v2.2 DB from my existing blog at dadthing.com, ran the upgrade script on the local installation with no errors.

    However, now when I visit http://localhost/ I get redirected to http://dadthing.com...!?

    I changed the "site_url" entry in "wp_options" using phpMyAdmin to "http://localhost/", but I still get redirected to "http://dadthing.com"...

    How do I keep this from happening so that I can test my blog setup on a local installation before rolling it out to the public?

    Thanks,
    Jared

  2. moshu
    Member
    Posted 6 years ago #

    You need to change the site_url AND the "home" value, too.

  3. Chris_K
    Member
    Posted 6 years ago #

    WordPress stores URL values in the database. You found one but there are actually two to change.

    Traditionally, we’d have to go spelunking through the Options table to find and change them (follow the link above).

    However, there’s an easier way introduce in a recent version of WP. We can now override these URL values directly in the wp-config.php file.

    define('WP_SITEURL', 'http://localhost/foo');
    define('WP_HOME', 'http://localhost/foo');
  4. dadthing
    Member
    Posted 6 years ago #

    Thanks everyone. It is working now!

    Thanks again,

    Jared

  5. ivow
    Member
    Posted 5 years ago #

    Thanks! Worked like a charm :)

Topic Closed

This topic has been closed to new replies.

About this Topic