WordPress.org

Ready to get started?Download WordPress

Forums

404 Redirected
Redirect not working without trailing slash... (4 posts)

  1. Trevor Gehman
    Member
    Posted 1 year ago #

    I can redirect /help/ successfully to a page, but not /help.

    It finds the 404 in the Log and says it served the 404 page, even though I have redirects enabled for both /help/ and /help....

    Any idea what could be causing this?

    http://wordpress.org/extend/plugins/404-redirected/

  2. Jesse
    Member
    Posted 10 months ago #

    It looks like they're actually handled as two distinct URLs. I'm running into the same problem on one site, and the only currently solution I'm seeing is to explicity define both as separate URLs.

    I'd be interested in seeing your logs for both URLs, I had one redirect that resolved to blank (in the database, it was trying to resolve to a PID that didn't exist).

  3. msnook
    Member
    Posted 7 months ago #

    I'm having the same problem. I have redirects set up for both with and without the slash, but the no-slash version is not working. The only other real resource I've found on this is a question with only 2 votes and no real answer on stackoverflow: http://stackoverflow.com/questions/9342645/add-trailing-slash-to-404-url-so-it-can-be-redirected .

  4. Svard
    Member
    Posted 6 months ago #

    Is it any solution if this issue? Is it realy nessery to do it twise, with and without last slash?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.