WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Redirect Loop + Trouble Logging in as Admin (9 posts)

  1. erichschuler
    Member
    Posted 2 years ago #

    I was in the general settings of my blog changing the URLs from http://www.erichschuler.com/blog to erichschuler.com/blog. As soon as I did this change, I was logged out and my blog started to get the "redirect loop" error message. The message is below:

    "The webpage at http://erichschuler.com/blog/ has resulted in too many redirects. Clearing your cookies for this site or allowing third-party cookies may fix the problem. If not, it is possibly a server configuration issue and not a problem with your computer."

    I've already cleared my cookies, but I still get the same problem.

    When I try to log in as the admin, for some reason none of the passwords I enter are being recognized and when I request for my lost password I receive no e-mail.

    Has anyone experienced this before? Any help would be greatly appreciated.

  2. You'll need to go into your phpmyadmin, go to your table options and reset the url to what it was.

    Then when you want to change your blog url, make sure you follow these steps - http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory

    What you want to do is change the site address, but leave the WordPress as is and then follow the instructions for the index.php

  3. erichschuler
    Member
    Posted 2 years ago #

    Can I access phpmyadmin through FTP? If so, where can I find it? Thanks for posting up the steps for changing a blog URL.

  4. erichschuler
    Member
    Posted 2 years ago #

    Sorry, I'm pretty new at this. How do I access my table options?

  5. karban
    Member
    Posted 2 years ago #

    Hi,
    to get to phpmyadmin:
    - Log onto your server / CPanel.
    - Within your CPanel, on the main page after you log in there will be rows of icons - look for the one for phpmyadmin. Click it & then it will open up in a new window. On the left side there should be a list of all your databases, click on the DB that you want to edit & then that database will open up.

    Once opened, on the left hand side of the page / screen there should now be a list of all the various tables within the database, and on the right-hand side of the screen there will be the same list but in more detail. You can access any of the tables by clicking on the edit link next to each of the tables (this opens up the table, and you can edit it & then save).

    Hope this helps!
    PS: Incidentally, the reason your site messed up is because you essentially changed the domain name & it could no longer find your site - there are better ways to remove the www from your URL address. An easy way for a newbie is probably to just use a redirection plugin, or change it via the (website's) htaccess file... You need to do some sort of redirection unless it's a new site otherwise it can be harmful for SEO, lost traffic etc.

  6. erichschuler
    Member
    Posted 2 years ago #

    Thanks for the help! I still have not been able to fix my problem, but I did manage to get into phpmyadmin. I found my database and went to a table called wp_iue72k_options and changed the siteurl from http://erichschuler.com/blog to http://www.erichschuler.com/blog. I am missing anything? The site comes up with the same error message.

  7. There's also another setting called home. That one needs to be set to the same thing.

  8. erichschuler
    Member
    Posted 2 years ago #

    Where do I find the home setting?

  9. erichschuler
    Member
    Posted 2 years ago #

    Nevermind, it turns out I was able to access my dashboard after changing the siteurl on phpmyadmin. And with access to the dashboard I was able to change the site site url back to the original url which solved everything. Thanks for the help everyone!

Topic Closed

This topic has been closed to new replies.

About this Topic