WordPress.org

Ready to get started?Download WordPress

Forums

Redirect Issue Does not Allow Me In Dashboard (29 posts)

  1. gregbd
    Member
    Posted 8 years ago #

    I reorganized my site and changed from index.php to index3.php and now when I try and login to dashboard it gives me a 404 error. I can get to the logon page but again produces a 404 error, whih means I cannot get into the dashboard.

    Ok, this issue is my own doing but I would really appreciate where to start working to resolve this issue because I am stumped.

  2. moshu
    Member
    Posted 8 years ago #

    changed from index.php to index3.php

    I don't think that will work. Although it would be good to know which index file was renamed? The sweet and short? In the theme?

  3. gregbd
    Member
    Posted 8 years ago #

    I changed from index.php to index3,php

  4. moshu
    Member
    Posted 8 years ago #

    Since almost in every folder there is an index.php file... WHICH one?

  5. gregbd
    Member
    Posted 8 years ago #

    Sorry at the root level, the main web level.

  6. gregbd
    Member
    Posted 8 years ago #

    I shoulkd also say that vefore I changed the file name, I went into dashboard > options and changed the two path references from domain.com/ to domain.com/index3.php

  7. moshu
    Member
    Posted 8 years ago #

    You can't do that - as I said in my first reply. WP is looking for that index.php file in many, many internal links. Renaming it... everything will be broken.

  8. moshu
    Member
    Posted 8 years ago #

    That's even worse!
    The two URI values can NOT end to a filename - only directory name.

  9. gregbd
    Member
    Posted 8 years ago #

    So if I move it to a directory, how do I fix this? Since I cannot get into the dashboard. I have tried to go in via phpmyadmin but it produces an error when I try to edit the table.

  10. gregbd
    Member
    Posted 8 years ago #

    I was able to get a MySQL Export, data dump. I guess my only option would be to rebuild it in a new directory with a fresh install? That would be one option.

  11. moshu
    Member
    Posted 8 years ago #

    I have tried to go in via phpmyadmin but it produces an error when I try to edit the table

    It shouldn't - if you did it in the right way. See if this guide helps:
    http://www.tamba2.org.uk/wordpress/site-url/

  12. moshu
    Member
    Posted 8 years ago #

    That would be one option.
    I don't think so. Just calm down and don't panic, please!

    Wait until you get useful directions on what to do, how to correct what went wrong and don't try to mess around with everything making things even worse.
    We will guide you through the process - just stop coming up with "ideas" :)

  13. gregbd
    Member
    Posted 8 years ago #

    Ok, I discovered that there is an issue with my connection with connecting with phpMyAdmin not connecting with MySQL.

    Do you recommend that I move the WordPress files to a new directory and then change the options to reflect a directory vs. a file?

  14. moshu
    Member
    Posted 8 years ago #

    To be honest I do NOT know what to recommend because I have no idea what kind of structure do you want for your site.
    Maybe if you give some more info - we can come up with a working solution.

  15. gregbd
    Member
    Posted 8 years ago #

    I need to use index.php at the root of my domain for another application. Therefore I was thinking that I could simply move all the WordPress files into a new directory and then change the site url and home page url using phpMyAdmin to reflect the new directory.

    I was hoping to be able to keep wordpress at the root level of my domain using index3.php but it does not look like that is an option. Did I provide enough information to come up with a solution?

  16. moshu
    Member
    Posted 8 years ago #

    I hope so :)
    If you need to have something else on the root index.php - then the only (simple) option is to move your WP install into it's own directory of your choice: it can be named whatever you want. Then have a link pointing to your blog from the home/main page of the site (if needed).

    For the move you can proceed as you described, or:
    1. go admin > Options
    2. Change the two URI values to the new location
    3. Do NOT open your blog in a browser! (IMPORTANT)
    4. Move the WP files to the new location
    5. Now you can open your blog

  17. gregbd
    Member
    Posted 8 years ago #

    I follwed your directions 1 through 5 and move the files, changed the name of the index3.php to index.php but now the index page does not even load... I cannot see any source code.

  18. moshu
    Member
    Posted 8 years ago #

    changed the name of the index3.php to index.php

    If you mean the index.php in the directory where you moved WP, that should look like this - nothing else:
    <?php
    /* Short and sweet */
    define('WP_USE_THEMES', true);
    require('./wp-blog-header.php');
    ?>

  19. gregbd
    Member
    Posted 8 years ago #

    I got that file... it is intact.

  20. moshu
    Member
    Posted 8 years ago #

    Did you succeed to change the two URI values (blog and WP URI) before making the move?

  21. gregbd
    Member
    Posted 8 years ago #

    Did you succeed to change the two URI values (blog and WP URI) before making the move?

    You bet.

    I noticed in the move that the CHMOD settings were different than one of my other funtioning blogs. They were 644 vs 755

    Could that now become an issue?

  22. moshu
    Member
    Posted 8 years ago #

    Files or folders?
    Generally, for folders should be 755, and for files - 644.

  23. gregbd
    Member
    Posted 8 years ago #

    files were 644 folders 755

  24. moshu
    Member
    Posted 8 years ago #

    I am running out of ideas and my "psychic" skills are down, too. So, a direct lionk to the blog at this moment would be quite beneficial...

  25. gregbd
    Member
    Posted 8 years ago #

  26. moshu
    Member
    Posted 8 years ago #

    1. Is the index.php of the active theme in place?
    2. Is any of the themes chosen as "active"? (admin > Presentation > click on a theme)

  27. gregbd
    Member
    Posted 8 years ago #

    I cannot get into any page.

  28. gregbd
    Member
    Posted 8 years ago #

    Everything is there...

  29. frankj
    Blocked
    Posted 8 years ago #

    Hi

    I have found what the issue is with this:

    1) You may have added this site to the "blocked cookie list" - delete it from there
    IE: tools > internet options > privacy > sites > look under managed sites
    If your site is there, delete it

    2) Make sure your browser is accepting cookies for this site
    Between the login and the re-direct to the correct admin page it seems like WP reads
    the cookie, if it ain't there, it will just redirect to the wp-admin page again
    IE: tools > internet options > privacy > sites > in address of website type your
    url with http:// in front and click "allow"

    3) Test by setting your security level to low.
    IE: tools > internet options > privacy > drag lever down to "accept all cookies"

    You may need to apply just 1 or all of them for it to work.

    Hope you get it working & God Bless

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags