WordPress.org

Ready to get started?Download WordPress

Forums

Use Google Libraries
"Redefining already defined constructor" error (7 posts)

  1. Simon Hampel
    Member
    Posted 1 year ago #

    You include a "PHP 4 Compatible Constructor" in your class JCP_UseGoogleLibraries

    In PHP 5.4 with WordPress debug mode turned on, this causes an error to be generated:

    Strict standards: Redefining already defined constructor for class JCP_UseGoogleLibraries in ... /wp-content/plugins/use-google-libraries/use-google-libraries.php on line 123

    According to the WordPress Requirements, WordPress has required at least PHP 5.2.4 since version 3.2

    I suggest that you increase your "Requires at least" to 3.2 and drop PHP 4 support - including removing your PHP 4 Compatible Constructor.

    http://wordpress.org/plugins/use-google-libraries/

  2. Jason Penney
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks, I'm aware of this. I'll be removing it.

  3. another-webmaster
    Member
    Posted 10 months ago #

    Any chance it will be updated soon?

  4. bassjobsen
    Member
    Posted 9 months ago #

    i also found when activating:

    Strict Standards: Only variables should be passed by reference in /home/bass/Dropbox/testomgeving/jamedotheme/wordpress/wp-content/plugins/use-google-libraries/use-google-libraries.php on line 335

  5. Jason Penney
    Member
    Plugin Author

    Posted 9 months ago #

    This other warning is due to a WordPress change, and I haven't figured out exactly what's causing it, but I am aware.

  6. Chirag Vora
    Member
    Posted 6 months ago #

    I'm too getting this one. Any ETA on updates?

  7. Jason Penney
    Member
    Plugin Author

    Posted 5 months ago #

    I think I know what needs doing, but I haven't had any time to do it. Hopefully soon.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic