WordPress.org

Ready to get started?Download WordPress

Forums

Red Security Warning about my post's URL (10 posts)

  1. resad
    Member
    Posted 1 year ago #

    I have been participating in some link parties. Out of nowhere, when I go to one of my posts (to share the URL on the link party) I get this warning, printed 3 times in red on the left side of my screen: SECURITY WARNING: Please treat the URL above as you would your password and do not share it with anyone.
    I've never encountered this before. What's going on?
    Thank you.

  2. Krishna
    Volunteer Moderator
    Posted 1 year ago #

    A possible hack/ intrusion/ malware?

    Can you post your URL?

  3. parham728
    Member
    Posted 1 year ago #

    its about facebook api

  4. Shane Jones
    Member
    Posted 1 year ago #

    Its a Facebook warning, make sure you API / code for any facebook stuff is up to date

  5. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    Somewhat off topic, but what is a "link party"?

  6. resad
    Member
    Posted 1 year ago #

    Shane: How do I make sure my API / code for any facebook stuff is up to date? I'm not tech savvy :/

    Krishna: I'm afraid to post the URL because of the warning! It comes up on every post I attempt to share now.

    WPyogi: A link party is something popular on food/lifestyle/mom blogs where bloggers are invited to link up and share current projects.

    Anyway, how do I check on my facebook code????
    My site is PitcherAndPlate.com

  7. Krishna
    Volunteer Moderator
    Posted 1 year ago #

    I'm afraid to post the URL because of the warning! It comes up on every post I attempt to share now.

    Do you get the warning from Facebook or from some other sources? Because your site has hundreds of links (or several hundreds, probably from your link party), it is very difficult to check if there is a warning from any particular link.

    There does not appear any security warnings while testing with standard tools (need not be 100% correct). However, your theme is either broken or outdated and shows a warning sign. Moreover, there is a very huge number of markup errors (289 errors and 106 warnings probably output by your theme) that you may need to deal with.

    Anyway, can you revert to Twenty Twelve theme and see if the warning still appears?

  8. rindymae
    Member
    Posted 1 year ago #

    Hi resad,

    I had this same issue on my blogger blog and today I ended up removing my facebook share button from my sidebar and all the share buttons that appear at the bottom of my posts. That seems to have taken care of the problem.

  9. Heaven's Disciples
    Member
    Posted 1 year ago #

    I'm having the same problem.

    It's being caused by the Simple Facebook Connect plugin.

  10. n-for-all
    Member
    Posted 1 year ago #

    this message comes as following:

    1- you write the fb javascript but you miss writing this code in your theme:

    <div class="fb-like" data-send="true" data-width="450" data-show-faces="true"></div>

    2- <div id="fb-root"></div>
    <script>(function(d, s, id) {
    var js, fjs = d.getElementsByTagName(s)[0];
    if (d.getElementById(id)) return;
    js = d.createElement(s); js.id = id;
    js.src = "//connect.facebook.net/en_US/all.js#xfbml=1";
    fjs.parentNode.insertBefore(js, fjs);
    }(document, 'script', 'facebook-jssdk'));</script>

    should be unique in your page and you don't need it more than once regardless of how many fb-like box or buttons are needed to be displayed on page.

    this happens mostly when you have 2 facebook plugins activated in your blog.

    hope that helps someone.

    cheers

Topic Closed

This topic has been closed to new replies.

About this Topic