WordPress.org

Ready to get started?Download WordPress

Forums

s2Member Framework (Member Roles, Capabilities, Membership, PayPal Members)
recv() failed: strange connection to host? (2 posts)

  1. marcio
    Member
    Posted 2 months ago #

    Hello,

    Yesterday I received this error which seems to be caused by a failed connection to the host: 151.52.65.115

    Here is the full error:

    2014/06/07 18:46:46 [error] 22805#0: *461085601 recv() failed (104: Connection reset by peer) while reading response header from upstream, client: 151.52.65.115, server: websitename.com, request: "POST /wp-admin/admin-ajax.php HTTP/1.1", upstream: "fastcgi://unix:/var/www/vhosts/system/websitename.com/php-fpm.sock:", host: "websitename.com", referrer: "http://websitename.com/wp-admin/admin.php?page=ws-plugin--s2member-paypal-ops"
    2014/06/07 18:47:53 [error] 22805#0: *461094423 recv() failed (104: Connection reset by peer) while reading response header from upstream, client: 151.52.65.115, server: websitename.com, request: "GET /wp-content/plugins/s2member/s2member-o.php?ws_plugin__s2member_css=1&qcABC=1&ver=140603-4094248687 HTTP/1.1", upstream: "fastcgi://unix:/var/www/vhosts/system/websitename.com/php-fpm.sock:", host: "websitename.com", referrer: "http://websitename.com/"
    2014/06/07 18:47:53 [error] 22795#0: *461094426 recv() failed (104: Connection reset by peer) while reading response header from upstream, client: 151.52.65.115, server: websitename.com, request: "GET /wp-content/plugins/s2member/s2member-o.php?ws_plugin__s2member_js_w_globals=1&qcABC=1&ver=140603-4094248687 HTTP/1.1", upstream: "fastcgi://unix:/var/www/vhosts/system/websitename.com/php-fpm.sock:", host: "websitename.com", referrer: "http://websitename.com/"

    The website then returned 502 bad gateway.

    This problem didn't happen all the time but only to some users and only in the wp-admin panel.

    Can anyone help me on this?

    Thanks

    https://wordpress.org/plugins/s2member/

  2. Cristian Lavaque
    Member
    Plugin Author

    Posted 2 months ago #

    You can try this, in case it spots something wrong with your configuration: http://www.s2member.com/kb/server-scanner/

    But I'd contact the webhost about it, since it seems to be a server issue.

Reply

You must log in to post.

About this Plugin

About this Topic