WordPress.org

Ready to get started?Download WordPress

Forums

All In One Schema.org Rich Snippets
[resolved] Recipe Snippet doesn't work (10 posts)

  1. juvetiko
    Member
    Posted 10 months ago #

    Hi all .
    I'm using your plugin and I like it , but it doesn't work on my recipe website . I didn't seen any change in Google search result (I have add a lot of new articles using your plugin) .
    Here is my website - howcooktasty.ru and here is example of new article - howcooktasty.ru/burrito-s-kartoshkoj-recept.html .
    Can anyone help me to solve this problem ?
    Thanks.

    http://wordpress.org/plugins/all-in-one-schemaorg-rich-snippets/

  2. Sujay
    Member
    Plugin Author

    Posted 10 months ago #

    Juvetiko,

    Kindly refer this frequently asked question and our usual response to it -

    Question - How much time does it take to show up rich snippets for my search results? My search results are still not coming up with rich snippets.

    Answer - Most probably rich snippets are displayed in for you search results as soon as search engines crawl the MicroData the plugin has created. However it's totally upto search engines to display rich snippets for your search result (which mostly depends on your website authority)

    If rich snippets are not appearing in your search results yet, most probably they will start appearing soon as Google / other search engines finds your website more authoritative.

    Meanwhile - you can validate and see preview of your rich snippets on http://www.google.com/webmasters/tools/richsnippets .

    Hope this is helpful to you :-)

    Regards,
    Sujay

  3. Jonathan Perret
    Member
    Posted 7 months ago #

    Hello,
    I am using the AIO ShemaOrg Rich Snippet plugin, and am getting the errors shown below with recipes, when I use the Google Webmaster Structured Data testing tool.
    Although I have a title introduced, it is indicating a missing field, and regarding the cook, preparation and total times, the site shows them correctly at, for example, 45M or 1h05, yet Google is interpreting PT45M, PT1h05, etc..??
    Any ideas??
    Thanks in advance,
    Jonathan Perret

    url: http://www.catacurian.com/category/spanish-food/
    Error: Missing required field "entry-title".
    Error: Missing required field "updated".
    Error: Missing required hCard "author".
    Item
    type: http://data-vocabulary.org/recipe
    property:
    photo: http://www.catacurian.com/wp-content/uploads/2013/11/arros-de-llamantol-2.jpg
    name: Lobster Paella
    published: 2013-11-17
    preptime: PT20M
    cooktime: PT45M
    totaltime: PT1h05
    review:
    Item 1
    Error: We did not accept "PT1h05" as cooking time.
    Error: Cooking time should be in ISO 8601 format - http://www.w3.org/TR/xmlschema-2/#duration
    Error: count field is 0.
    Error: Rating could not be normalized.

  4. Sujay
    Member
    Plugin Author

    Posted 7 months ago #

    Jonathan.

    My response inline of the particular errors -

    Error: Missing required field "entry-title".
    Error: Missing required field "updated".
    Error: Missing required hCard "author".

    ---> These errors are coming from the code of theme you are using. Please get in touch with the developer of your theme and he should be able to get you with this.

    _ _ _ _ _ _ _ _ _ _ _ _ _

    Error: We did not accept "PT1h05" as cooking time.
    Error: Cooking time should be in ISO 8601 format - http://www.w3.org/TR/xmlschema-2/#duration

    ---> You seem to have entered the time in incorrect format. You will need to enter it in correct format as explained where you enter the data. (Screenshot - http://d.pr/i/NAl6)
    (Try removing "PT" prefix that you have added and enter it as 1H30M or so in correct format)

    _ _ _ _ _ _ _ _ _ _ _ _ _

    Error: count field is 0.
    Error: Rating could not be normalized.

    ---> Since you have got no ratings as of yet to your posts, this error would come which is normal and obvious. Once you get get your first rating, the error will go.

    Hope this helps. If you need further professional help to get issues resolved which are in the code of your theme, you may ask for a professional service starting at $25 USD

    Regards,
    Sujay

  5. Jonathan Perret
    Member
    Posted 7 months ago #

    Thank you Sujay,
    Very quick response! I'll check out the theme issues, but here is the url of the post, http://www.catacurian.com/lobster-paella-arros-caldos-de-llamantol/
    and as you may see in the rich snippet box at the bottom, I haven't written the letters PT before the times. That is why I can't understand how they end up there with google?
    Thanks for your time and best regards,
    Jonathan

  6. Sujay
    Member
    Plugin Author

    Posted 7 months ago #

    Well - I'm not really sure on this but I guess, it must be an issue with theme or something.

    You can try this to identify the issue -

    1. Please disable all other plugins except AIOSRS temporarily and see if things work
    2. If not, temporarily switch to any other WordPress theme to check if the culprit is in the theme

    Best luck!

  7. Jonathan Perret
    Member
    Posted 7 months ago #

    Hi Sujay,
    Sorry to say, but the problem is in your "Function.php" file on lines 451,457 and 463, where there are the letters "PT" inserted at the datetime. Just removed those and got it solved.
    best regards,
    Jonathan

  8. Sujay
    Member
    Plugin Author

    Posted 7 months ago #

    Jonathan,

    Please don't edit anything from code as it'll produce more errors. I see they have started coming already since you removed PT from the code - http://goo.gl/N0AkSr

    _ _ _ _ _ _ _ _ _ _ _ _ _ _

    Error: We did not accept "1h05" as cooking time.
    Error: Cooking time should be in ISO 8601 format - http://www.w3.org/TR/xmlschema-2/#duration
    Error: We did not accept "20M" as cooking time.
    Error: Cooking time should be in ISO 8601 format - http://www.w3.org/TR/xmlschema-2/#duration
    Error: We did not accept "45M" as cooking time.

    _ _ _ _ _ _ _ _ _ _ _ _ _ _

    I analyzed more in your issue and found you are NOT entering "H" in BLOCK letters as shown in admin panel and instead have entered "h" as small letter.

    Just revert the changes you made in code, type "H" as block letter and your issue will be resolved.

    Hope this will help.

    Regards,
    Sujay

  9. Jonathan Perret
    Member
    Posted 7 months ago #

    Hello again Sujay,
    Thanks. Actually, after writing my previous response, I went back to Google testing, then went to lookup the ISO8601 rules, and saw that the PT was necessary, so I've corrected the function.php file back to its original version. As you noticed, I had mistakingly typed a small case "h" instead of the capital "H"....Must have been during one of those sleepless nights.....
    I'll check my other posts and keep monitoring google structured data.
    Thanks a lot for your time and help.
    best regards,
    Jonathan

  10. Sujay
    Member
    Plugin Author

    Posted 7 months ago #

    You are welcome Jonathan.

    By the way, I was wondering if you might able to spend a moment to support this free plugin with quality support? If you don't mind, I'd really appreciate if you could rate plugin with five starts and leave a brief testimony for the plugin and support we provide on WordPress.org

    This is just to help other users make a comfortable decision while choosing the plugin and to help us spread AIOSRS Plugin to maximum people.

    Here is the link to do this - http://wordpress.org/support/view/plugin-reviews/all-in-one-schemaorg-rich-snippets#postform

    Best luck & regards!

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.