WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
[closed] Recently an error occurred while creating the CSS / JS minify cache: (48 posts)

  1. edcs
    Member
    Posted 1 year ago #

    Recently just started using W3TC again after the recent updates - looking good so far, but unfortunately Minify is causing me grief again. I'm getting the following error message with it enabled:

    Recently an error occurred while creating the CSS / JS minify cache: No sources to serve.

    When I go to the Minify URL (Just testing with JS files at the moment), I get the following error message:

    HTTP/1.0 400 Bad Request

    If I turn on WP_DEBUG I get no further information. I've got W3TC running on a Multisite installation of WordPress so I have no option to select which files get Minified manually. I assume the plugin finds files using wp_enqueue_script() and wp_enqueue_style() so perhaps I'm doing something wrong when defining those in my custom themes?

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. edcs
    Member
    Posted 1 year ago #

    Any thoughts?

  3. Frederick Townes
    Member
    Plugin Author

    Posted 1 year ago #

    Sorry for the trouble, this is improved in the next release.

  4. Jonathan Dingman
    Member
    Posted 1 year ago #

    I'm seeing the same error. Looking forward to the next release Frederick!

  5. andybritnell
    Member
    Posted 1 year ago #

    I'm getting a similar issue with a particular file.

    Recently an error occurred while creating the CSS / JS minify cache: File "/var/www/vhosts/workfromhomewisdom.com/httpdocs/wp-content/plugins/pinterest-pin-it-button/css/pinterest-pin-it-button.css" doesn't exist

    What do I do to clear this error? The pinterest plugin was deleted - has it left behind a file?

    Many thanks

    Andy

  6. WAmadeusM
    Member
    Posted 1 year ago #

    I also have this error. Very much a newbie to WP although not to computers.
    The site is:
    besthairsalonseattle.com
    The error I receive is:
    Recently an error occurred while creating the CSS / JS minify cache: File "/home/cobra47/public_html/wp-content/themes/hair_theme/js/small-menu.js" doesn't exist.

    I've also cleared the cache. I do not see anything in the settings that indicates a way to correct this error.

    Regards,

    Mike

  7. edcs
    Member
    Posted 1 year ago #

    Just updated to the latest version, I'm sorry to say that I'm still getting the same problem :(

  8. alhalkab
    Member
    Posted 1 year ago #

    same problem too, latest version

  9. Click-Factor
    Member
    Posted 1 year ago #

    Hello to all.

    I confirm that even with the latest version 0.9.2.9 I get the same error.

  10. DarenG
    Member
    Posted 1 year ago #

    I just started receiving this same error a couple days ago on my site. Any word yet on a fix?

  11. usascholar
    Member
    Posted 1 year ago #

    I am using:
    Version 0.9.2.10 | By Frederick Townes

    Minify now breaks my website, when the last version did not... and it is now uncompatible with "WordPress GZIP Compression"... which I find stupid.

    What gives? Are the new bugs a feature?

  12. Watch Teller
    Member
    Posted 1 year ago #

    Me too. Downgraded to 9.2.9 also lots of W3TC's options not function well.

    Especially minify options.

  13. ib.property
    Member
    Posted 1 year ago #

    I solved the problem manually emptying page cache every time I see the red notice. But of course this is just a temporary solution.

  14. DarenG
    Member
    Posted 1 year ago #

    I tried manually emptying page cache as well but it did not solve the problem for my site.

  15. Eddie - Digital Marketing Consultant
    Member
    Posted 1 year ago #

    Using 0.9.2.10 on WP 3.5.1, I get, every few hours after Minify is enabled, the following alert in wp-admin:

    CSS / JS minify cache: File "/home/mysite/public_html/wp-content/themes/style.css" doesn't exist

    The front end of the site throws a 500 but nothing gets logged by Apache.

    I've disabled Minify completely.

  16. ib.property
    Member
    Posted 1 year ago #

    In fact, my Minify was already partially working before the update: I enabled only html and css inline.

    JS and CSS were already disabled.

    Now, after the first manual empty, the red notice is no more present.

  17. edcs
    Member
    Posted 1 year ago #

    It doesn't sound like any of you are having the same problem, unless you're all forgetting to mention you're running multi-site. I'd appreciate it if you started your own support threads because your issues don't seem to be related to mine.

    I'm still getting the same problem when trying to minify, however now I'm getting a more useful error message:

    Minify Auto does not work properly. Try using Minify Manual instead or try another Minify cache method. You can also try a lower filename length value manually on settings page

    This gives me a link to a settings page, but I then get a permission denied message. I presume this is because I'm using multi-site and the plugin is in community mode as the link directs to the W3TC settings for that particular site. Anyway, if I manually go to the Minify settings and reduce the file name length to something shorter, like 25, I still get the same error.

  18. edcs
    Member
    Posted 1 year ago #

    Found another message too:

    Recently an error occurred while creating the CSS / JS minify cache: Url/Filename is too long: 0/edcs.me/assets/js/jquery-1.7.2.min. Max length is 25.

    Should that message be showing the full file path? The 0 and the missing .js extension worries me.

  19. Eddie - Digital Marketing Consultant
    Member
    Posted 1 year ago #

    I'm NOT running multisite. But IMHO the issue is still the same (minify functionality is broken).

  20. treccase
    Member
    Posted 1 year ago #

    After 8 hours of trying , the only thing I minified was my penus. Please make it work.

  21. ib.property
    Member
    Posted 1 year ago #

    After the updating to 0.9.2.11 the situation is even worst: with 0.9.2.10 the message error disappeared when manually emptied the cache. Now doesn't.

  22. edradour
    Member
    Posted 1 year ago #

    I'm getting similar errors using 0.9.2.11
    If minify is set to auto, I receive a file length message and a recommendation to shorten the length of my file names. If set to manual, files are not found.

    The latest message is:
    "Recently an error occurred while creating the CSS / JS minify cache: File "path_to_wordpress/wp-content/themes/art/js/weaverjslib.min.js" doesn't exist."

    My art theme is a child theme of Weaver II, and and the 'missing' file resides on the parent theme's path

  23. ib.property
    Member
    Posted 1 year ago #

    My theme is twenty twelve pure with no child. Js and Css minify disabled. Only htlm and css inline enabled.

  24. edradour
    Member
    Posted 1 year ago #

    Just received an e-mail from my site:

    Unfortunately, an error occurred while creating the minify cache. Please check your settings to ensure your site is working as intended.
    Thanks for using W3 Total Cache.
    ---

    Due to my Minify issues, Minify is was been disabled when I posted my message above ... so I should not have received the e-mail

  25. ali.chakery
    Member
    Posted 1 year ago #

    I have the same issue with 0.9.2.11 ... any solutions ?

  26. Marco Panichi
    Member
    Posted 11 months ago #

    Same problem here

  27. honeysmith
    Member
    Posted 11 months ago #

    I have this problem aswell. I'm using wp 3.6.1 and W3 Total Cache 0.9.3

    Any help with this would be appreciated.

    Thanks.

  28. ali.chakery
    Member
    Posted 11 months ago #

    For me it shows me an error when I try to test the CDN connection but it works fine , I mean I am able to serve my files from CDN using this plugin ...

    try to play with it , you can test your website using webpagetest.org to see if the CDN is working or not.

  29. Vidyut
    Member
    Posted 11 months ago #

    I have this error with the latest version + latest wordpress as of today.

  30. michael.oeser
    Member
    Posted 11 months ago #

    Same issue here at WP 3.6.1 and W3TC 0.9.3

    "Recently an error occurred while creating the CSS / JS minify cache: No sources to serve."

    Would be nice if the developers could help us.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic