WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
recent update killed sitemap (20 posts)

  1. Nic Windley
    Member
    Posted 9 months ago #

    Sitemap no longer generates upfter recent update

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. Joost de Valk
    Member
    Plugin Author

    Posted 9 months ago #

    Hi Nic,

    so far I don't see any problems, so please do show me your sitemaps URL so we can test.

  3. Nic Windley
    Member
    Posted 9 months ago #

    Hi Joost,

    Actually I had to drop WP SEO altogether as I'm finding it a BIG consumer of RAM coupled with the latest sitemap issue. Had to use another plugin that I found was far more RAM efficient I'm afraid.

    Thanks for offering to take a look though.

    Nic

  4. wadewa
    Member
    Posted 9 months ago #

    Hi
    I have the same problem.
    Here is the URL :
    http://www.littledancer.fr/sitemap_index.xml
    Don't know if it could help, but I use w3 total cache and cleared cache
    Thanks
    Wadewa

  5. jlcoleman71
    Member
    Posted 9 months ago #

    I'm having issues as well, I updated to the latest version of WP sa well as the WordPress SEO plugin when the problems started....here's the URL:

    http://bestbanksnearme.com/sitemap_index.xml

  6. jrf
    Member
    Posted 9 months ago #

    @wadewa: it looks like a space is being output before the xml is send which is causing an issue.
    Have you tested with other plugins disabled ?

  7. jlcoleman71
    Member
    Posted 9 months ago #

    I reset to the default Twenty Twelve theme and disabled all other plugins....still not working, giving the same error message.

  8. jrf
    Member
    Posted 9 months ago #

    @jcoleman - your sitemap is having a different problem from @wadewa's, let's keep the threads seperate....

  9. Arendell
    Member
    Posted 9 months ago #

    Go to "XML Sitemaps" tab and uncheck for disable it then save and check to enable it then save.

    It's work for me.

  10. wadewa
    Member
    Posted 9 months ago #

    @jrf Thanks for the tip. I desactivated all plugin except seo + activate default wp theme. Same issue. Then I try the advice just above. I still get the issue.

    I think it comes from the plugin or my host conf.
    The problem appear with last update 1.4.13.
    I'm also using last wordpress version atm : 3.5.2

    Everything worked perfectly with 1.4.12
    Wadewa

  11. Joost de Valk
    Member
    Plugin Author

    Posted 9 months ago #

    Did any of you by any chance make changes to the htaccess for XML sitemaps?

  12. wadewa
    Member
    Posted 9 months ago #

    So I try to switch back to 1.4.12 and it works again.
    Even if it's not a solution I keep that version to still have sitemap.
    If someone can have a better solution or need to check my not working sitemap I Will follow!!

  13. wadewa
    Member
    Posted 9 months ago #

    @joost no change at all in htaccess or something else
    The issue appeared right after the update

  14. Joost de Valk
    Member
    Plugin Author

    Posted 9 months ago #

    Hmm one more option: go to Settings -> Permalinks and save settings there, that might fix it...

    Also: the sitemaps always work. This is an issue with the XSL file, the style sheet, not working.

  15. wadewa
    Member
    Posted 9 months ago #

    So I tried this fix :
    First update to 1.4.13, save permalink settings
    No success

    Then try to disable XML, reactivate it, save permalink settings
    No success

    Last test : desactivate plugin, save permalink, reactivate plugin, save permalink
    No success

    As sitemap always work (also seen it in google webmaster tool) I keep this last version.

  16. rtwlabs
    Member
    Posted 9 months ago #

    I've noticed this as well but I'm only working on nginx hosts so thought that might be the case. Sitemap page just generates a white page and have tried across to differnet nginx servers.

    tried disabling and re-enabling it but no joy. tried re-saving the permalinks as well.

  17. jlcoleman71
    Member
    Posted 9 months ago #

    I did not make any changes to the htaccess for XML sitemaps.

  18. simonmc
    Member
    Posted 9 months ago #

    ignore

  19. martincid
    Member
    Posted 9 months ago #

    I had the same problem here and I solved it. And this causes that google news isn't indexing our news either. I tried twice and I had no luck.
    I was working then with 1.4.7 version. I did this:
    1.- Update to latest version.
    2.- Change permalink. Save.
    3.- Change permalink again to previous. Save.
    4.- Disable XML sitemaps. Save.
    5.- Enable again. Save.

    And... done! Thanks for this plugin. It's helping us a lot.

  20. wadewa
    Member
    Posted 9 months ago #

    It didn't work here...

Reply

You must log in to post.

About this Plugin

About this Topic