WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] recent comments plugin; frustration level high! (10 posts)

  1. Joni
    Member
    Posted 8 years ago #

    I'm trying to find a viable recent comments plugin. One throws out php errors and the other is bereft of any instructions as to code to create the output.

    If I sound frustrated, it's because I am. Don't ask me to search this forum for "recent comments" posts because I did. I either followed rabbit trails or was met with 500/Internal Server Errors on some posts. (This happened earlier with another problem I was having regarding PHP inside WP pages.)

    Problem: With Nick Mowrik's Recent Comments Plugin (obtained here: http://dev.wp-plugins.org/browser/recent-comments/), the site throws out the following error on the sidebar:

    Parse error: parse error, unexpected '<' in /home/joniadau/public_html/wp-content/themes/angel/sidebar.php on line 37

    Problem: With LCF-Recent Comments (obtained here: http://www.liewcf.com/blog/archives/2004/04/added-recent-comments-list/), my hands are tied as there simply is no instruction whatsoever about what tags or output to use to get it to work.

    The site is here:

    http://adaugeo.net

    As of right now, I left the Mowrik plugin up, as it was the only one for which I had concrete documentation, plus you can see the error it's giving. The second plugin (LCF) MIGHT work, heaven knows, but I don't know what code to put in the sidebar to make it do anything. BTW, I also have an email in to the LCF plugin's author, so hopefully he will weigh in with some advice. But I was hopeful that someone here might have gotten it to work.

    Thanks for any help.

  2. James
    Happiness Engineer
    Posted 8 years ago #

  3. Joni
    Member
    Posted 8 years ago #

    Thanks, MacManx! I'll check them out this evening! I'm not partial to one or the other plugin -- I'm actually just partial to whichever one works! ;->

  4. Joni
    Member
    Posted 8 years ago #

    Well, I tried Brian's latest comments:
    http://meidell.dk/archives/category/wordpress/latest-comments/

    and it worked but the output seemed sparse.

    The Coffee2Code plugin:
    http://www.coffee2code.com/archives/2004/07/08/plugin-toprecent-comment

    wasn't exactly what I was after, as it focused more on the commenters and not the fact that there were recent comments and what those comments are.

    The third one:
    http://blog.jodies.de/archiv/2004/11/13/recent-comments/

    was, indeed, the charm! I love the interface; very easy to customize right there on the WP console. It's lovely.

    Check out the site now:
    http://adaugeo.net

    I think it looks much better. Thanks so much for the tips, MacManx!

  5. pericat
    Member
    Posted 8 years ago #

    "parse error" is PHP's way of saying "typo". You had a typo in your sidebar, on or near line 37, that prevented PHP from even beginning to evaluate the line in which you called Nick's Recent Comments plugin.

    Should you run into one of these again (I, myself, have seen dozens if not hundreds), check your typing. Most common typos are forgetting closing parens or quotemarks, or leaving out (or misplacing) the statement-ending semi-colon, or mis-keying the <?php or ?> parts.

  6. Denis de Bernardy
    Member
    Posted 8 years ago #

  7. monkeypup
    Member
    Posted 8 years ago #

    Denis' is my favorite!

  8. mkgago
    Member
    Posted 8 years ago #

    Can anyone help with this? I'm using this plugin for recent comments:

    http://blog.jodies.de/archiv/2004/11/13/recent-comments/

    but after upgrading to 1.5.1.3, I've been unable to access the options through the dashboard.

    The plugin itself still works, but its format is frozen in the way I originally set it up until I can get into the dashboard to play with it.

    The author of the plugin seems to be having trouble figuring out what is wrong -- I'm not the only one having this problem. See the most recent comments (heh) on the link above.

    Here is the error I get through Dashboard--Options--Recent Comments:

    Fatal error: Cannot redeclare kjgrc_subpage_misc() in
    [...]/public_html/blog/wp-content/plugins/get-recent-comments.php on line 22

    I'm using version 1.1-TEST6 of the plugin, and WP 1.5.1.3

    thanks in advance for your help.

  9. Ajay
    Member
    Posted 8 years ago #

    I have the same problem and have contacted the author for the same

  10. mkgago
    Member
    Posted 8 years ago #

    He seems to be unable to replicate the error you or I are getting, Ajay. Can anyone else help?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags