WordPress.org

Ready to get started?Download WordPress

Forums

Recent Category, repeating posts (Theme: TheSource) (1 post)

  1. Prodak
    Member
    Posted 2 years ago #

    Hello, my blog is http://www.thedebb.net

    Im using TheSource theme by elegant themes. However I had to deactivate the recent category post bar, because its repeating the last post in every category, no matter what. (I've 4 categories and 1 post in each category) the theme is supposed to have a bar with a post for your favorite 4 categories (including thumbnail)... but if I activate it (and set it up correctly at epanel) I get first post from general cat working fine.. all other 3 categories are the last post... why is this.. maybe the database is corrupted.. slug names? I think i changed the name of the categories many times before I started my blog.

    See how it should look like: http://www.elegantthemes.com/gallery/thesource/

    Im copy pasting what is in /includes/recent-cat.php:

    <div class="top<?php if($last) echo(" last"); ?>">
    <h4 class="title"><?php echo(esc_html(get_option($cat_option))); ?></h4>
    </div>

    <?php $thumb = '';

    $width = 239;
    $height = 133;
    $classtext = 'thumb';
    $titletext = get_the_title();

    $thumbnail = get_thumbnail($width,$height,$classtext,$titletext,$titletext);
    $thumb = $thumbnail["thumb"]; ?>

    <?php if ($thumb <> '') print_thumbnail($thumb, $thumbnail["use_timthumb"], $titletext , $width, $height, $classtext); ?>

    <div class="entry <?php echo($headingColor); ?>"<?php if ($thumb == '') echo(' style="padding-top: 70px;"'); ?>>
    <div class="title"<?php if ($thumb == '') echo(' style="top: 13px;"'); ?>>
    <h3>"><?php the_title(); ?></h3>
    </div>
    <p class="meta-info"><?php esc_html_e('Posted by','TheSource') ?> <?php the_author_posts_link(); ?> <?php esc_html_e('on','TheSource') ?> <?php the_time(get_option('thesource_date_format')) ?></p>
    <p><?php truncate_post(182); ?></p>
    " class="readmore"><span><?php esc_html_e('Read More','TheSource'); ?></span>
    </div>

    Any idea.. how can I fix this.. I really appreciate it

Topic Closed

This topic has been closed to new replies.

About this Topic