WordPress.org

Ready to get started?Download WordPress

Forums

BFT Autoresponder and Newsletter
Receiving emails day 1 onwards (8 posts)

  1. ollyw
    Member
    Posted 1 year ago #

    Hi,
    I'm hoping to upgrade to the Pro version to deliver online educational courses via email, however I'm struggling to get BFT Light working. Upon signing up the 'welcome email' (day 0) is received no problem. However day 1, 2... emails are not being sent.

    My WP site is new and so there are no visitors yet, so I started a cron job to 'visit' the site every day, as I understand that this is necessary for the plugin to work:

    Minute: *
    Hour: */3
    Day of Month: *
    Month: *
    Day of week: *
    Command: wget -O - -q -t 1 http://gcsephysicsninja.co.uk

    Note entirely sure if I've got this right?

    I'm currently using the Configure SMTP plugin and delivering mail via Google. I've also tried without SMTP, but still nothing.

    Any suggestions much appreciated - I really like the plugin and hope that the Pro version will be an option for me :)

    http://wordpress.org/extend/plugins/bft-autoresponder/

  2. ollyw
    Member
    Posted 1 year ago #

    Just thinking aloud... is there a specific url to which the wget command applies (as the BFT signup page is not the home page)?

  3. prasunsen
    Member
    Plugin Author

    Posted 1 year ago #

    It's hard to say what could be the problem from distance. But most probably the cron job is not working. Maybe you can look at the server error log. Sorry, there isn't much we can do.

  4. prasunsen
    Member
    Plugin Author

    Posted 1 year ago #

    In fact if you are getting the 0 day email, for sure the problem is with the cron job, not with the SMTP configuration.

  5. ollyw
    Member
    Posted 1 year ago #

    That's for the speedy reply! I'll check out the cron job with the host and let you know what I find.
    Cheers :)

  6. ollyw
    Member
    Posted 1 year ago #

    Hi again, just an update...
    Looks like the host (shared) doesn't allow cron jobs, so I've set an external cron job to run every day from setcronjob.com

    The url visited by the cron job is http://gcsephysicsninja.co.uk

    I tried registering again using a different email address and again received the day 0 email, but no further emails for day 1, 2 or 3.

    Hmm.. Not sure what else to try here as the cron job did visit the site on the last two days, but no emails sent.

    Is there a particular url that needs to be visited (a page perhaps with some part of the autoresponder code that 'activates' when visited)?

    Hope I'm not missing something really obvious here...

    Thanks again,

    Olly

  7. prasunsen
    Member
    Plugin Author

    Posted 1 year ago #

    By visiting the homepage, email sending is activated. Unfortunately that's all I can say, no way to know why it wouldn't work for you. I'm unable to support individual cases at this point.

  8. lone77star
    Member
    Posted 1 year ago #

    Hi Ollyw,

    In my own attempts to get cron working, I ran across an article that suggested,

    wget -q -O - http://yourdomain.com/blog/wp-cron.php?doing_wp_cron >/dev/null 2>&1

    Naturally, you need to change this to the path to your own wp-cron.php file.

    And suggested adding,
    define('DISABLE_WP_CRON', true);
    to the wp-config.php to disable the internal cron job.

    Hope this helps.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic