WordPress.org

Ready to get started?Download WordPress

Forums

Easy Modal
[resolved] recaptcha for contact form 7 not working in easy modal (10 posts)

  1. johnmartelle
    Member
    Posted 8 months ago #

    I have a contact form using contact form 7 opening in your plugin. Within the contact form I have a recaptcha using the recaptcha plugin. The contact form shows everything but the captcha. Any ideas what is going on here?

    http://wordpress.org/plugins/easy-modal/

  2. danieliser
    Member
    Plugin Author

    Posted 8 months ago #

    I havent personally tested that. Do you have a live example i can see.?

  3. johnmartelle
    Member
    Posted 8 months ago #

    I currently have it on a localhost dev site. The wierd part is that when you try and submit the form it throws a validation error because the captcha wasn't filled out.

  4. danieliser
    Member
    Plugin Author

    Posted 8 months ago #

    Strange, it sounds like its css/js may not be loading properly.

  5. johnmartelle
    Member
    Posted 8 months ago #

    Easy modal css/js or the recaptcha plugin?

  6. johnmartelle
    Member
    Posted 8 months ago #

    Also the theme settings aren't being updated when I change them.

  7. johnmartelle
    Member
    Posted 8 months ago #

    I fixed the theme settings.

  8. danieliser
    Member
    Plugin Author

    Posted 8 months ago #

    The recaptcha doesn't seem to be loading. This may be because it's plugin tries to detect if it's being used and then calls the correct scripts and CSS. Since modals are loaded in the footer this may cause that detection to fail.

    There are similar issues with gravity forms and other plugins. But there are fixes and workarounds but they are specific to each plugin.

  9. johnmartelle
    Member
    Posted 8 months ago #

    I have decided to discontinue the use of the recaptcha plugin in favor of contact form 7 built in quiz system. This eliminates two plugins which should lead to better page load times. Thank you for the help. This will be marked as resolved.

  10. danieliser
    Member
    Plugin Author

    Posted 8 months ago #

    Glad you got it working. Will try to find the problem for future versions.

    Please take a moment to rate and review the plugin and or support. Thanks
    http://wordpress.org/support/view/plugin-reviews/easy-modal

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.