WordPress.org

Ready to get started?Download WordPress

Forums

Really Simple Captcha Not Working in Subdirectory (6 posts)

  1. Rocknation
    Member
    Posted 4 years ago #

    This contact form contains CAPTCHA fields, but the temporary folder for the files (/wp-content/uploads) does not exist or is not writable. You can create the folder or change its permission manually.

    The uploads folder DOES exist, as does wpcf7_images and wpcf7_uploads. They're all CHMODed to fullest permissions possible. My php.info file says my GD and FreeType are enabled. But that's the message I get when I try to add Really Simple Captcha to Contact Form 7, even though I've deleted and re-installed them twice.

    The only potential problems I can think of are that the site is XHTML Strict and in a sub-directory--though I've added a php.ini file and a handler command to the sub-directory's .htaccess file. Under Settings/Miscellaneous on the WP dashboard, I have the uploads URL as http://www.maindirectory.com/subdirectory/wp-contents/uploads since wp-content/uploads didn't do the trick. Which puts me completely out of ideas!

  2. Takayuki Miyoshi
    Member
    Posted 4 years ago #

    Under Settings/Miscellaneous on the WP dashboard, I have the uploads URL as http://www.maindirectory.com/subdirectory/wp-contents/uploads since wp-content/uploads didn't do the trick.

    This must be the cause of your problem. It should be a folder path in your server's filesystem, not URL.

  3. Rocknation
    Member
    Posted 4 years ago #

    In the first line of Settings/Miscelleanous, I've tried

    wp-content/uploads (Default)
    /wp-content/uploads/
    wp-content/uploads/

    subDiretory/wp-content/uploads
    /subDiretory/wp-content/uploads/
    subDiretory/wp-content/uploads/

    rootDirectory/subDiretory/wp-content/uploads
    ...

    rootDirectory/public_html/subDiretory/wp-content/uploads
    ...

    rootDirectoryPassword/subDiretory/wp-content/uploads
    ...

    rootDirectoryPassword/public_html/subDiretory/wp-content/uploads
    ...

    home1/rootDirectory/public_html/subDiretory/wp-content/uploads
    ...

    home1/rootDirectoryPassword/public_html/subDiretory/wp-content/uploads
    ...

    None of them work--that's why I tried putting the URL path in the second line.

    P.S. Thanks for getting back to me at such and unseemly hour!

  4. Rocknation
    Member
    Posted 4 years ago #

    Duplicate post, sorry

  5. Rocknation
    Member
    Posted 4 years ago #

    Here's the latest: With /subDirectory/wp-contents/uploads/ in Settings/Miscellaneous (AND my config.php file), I can now get a text field but no CAPCHTA image. Am I getting warmer?

  6. Rocknation
    Member
    Posted 4 years ago #

    Okay, you can mark this case closed.

    The Fast And Secure Contact Form I installed worked on the first attempt. I've used Contact Form 7 and Simple Captcha several times before, but always on WP sites located in a root directory. I guess I threw them a curve by trying to install them on a site that's actually an add-on domain.

    I feel a little disloyal, but if I hadn't made a similar decision a few years ago, I probably wouldn't be here. I couldn't install Gray Matter, TrueType or WordPress through my old Web hosting service because they didn't have the right versions of Perl or PHP. Though they'd served me well for nearly a decade, I had to come to terms with the fact that I no longer had the right version of a Web hosting service!

    Thanks for your attention, help and interest anyway.

Topic Closed

This topic has been closed to new replies.

About this Topic