WordPress.org

Ready to get started?Download WordPress

Forums

Really Simple CAPTCHA
Really Simple CAPTCHA image doesn't appear (12 posts)

  1. ebigalee
    Member
    Posted 2 years ago #

    I installed Really Simple CAPTCHA to support Contact Form 7. I generated the tags within my form and added the code. It says "captcha" and has an empty field beneath it. The correct libraries are installed, the temp folder is writable, and I just don't know what's wrong or what else to try.

    http://www.indiana.edu/~ccc/interest-for-enrollment-form-waitlist/

    Help?

    http://wordpress.org/extend/plugins/really-simple-captcha/

  2. davidquiring
    Member
    Posted 2 years ago #

    This looks like the same issue I just solved for myself. Oddly my captcha WAS working when I set up the contact form on my site back in February, but today it was not (same issue - image not showing up). I don't test the functionality of it daily so I'm not sure at which point an update broke it.

    I went through the detective process which I'll outline here to make it easier for people to locate this solution from searching. First, I found that the image WAS being generated in my uploads folder (.../wp-content/uploads/wpcf7_captcha/) and all the folders and png/txt files had the proper public read permissions. Hmmm but for some reason when my captcha form referenced the image it returned a "403 Forbidden" message. Directly trying to access the file with my browser (.../wp-content/uploads/wpcf7_captcha/123456789.png) also returned the "403 Forbidden" error.

    After doing some research I found the problem to be with the .htaccess file that Really Simple Captcha is creating if there does not already exist one in the wpcf7_captcha folder.

    The solution? I edited the .htaccess file to only contain the text between these quotes:
    "Allow from all"

    The file they were creating tried to only allow for files with the image extension to be accessible directly but for some reason the syntax they used was failing. It might have something to do with my webhost being behind on an update or something, or an error in their code.

    Another solution would be to remove the existing .htaccess file altogether and then edit the plugin itself to not recreate the .htaccess file as it is not really needed. The function you would remove is called "make_tmp_dir".

    Hope this helps.

  3. MickeyRoush
    Member
    Posted 2 years ago #

    I would not recommend doing what davidquiring suggests. Setting "Allow from all" would allow a hacker to upload any type of file there. Like a PHP file for example. The author is trying to secure that directory. Without those rules or something similar in place it's the same thing as leaving your window open at home which would allow a burglar to climb in and do what they want.

    Try these rules instead:

    Order Allow,Deny
    <FilesMatch "^[0-9A-Za-z]+\.(jpe?g|gif|png)$">
    Allow from all
    </FilesMatch>
  4. Katch22
    Member
    Posted 1 year ago #

    I'm currently having this issue too. It was working but when I updated the plugin it now will not display the captcha.

    Everything is installed, the images are being created and I believe all of the permissions are correct. When testing things, I deleted the contents of .htaccess in the upload folder and the captcha appeared immediately.

    Obviously this isn't an acceptable solution, but the code MickeyRoush provided unfortunately doesn't work either! I've removed the captcha from the form for now but I would prefer to have it fixed and activated again - Any help would be appreciated! I've found surprisingly little referring to this htaccess issue :S

    Cheers!

  5. MickeyRoush
    Member
    Posted 1 year ago #

    @ Katch22

    What type of server are you on? Apache, Nginx, Windows, etc?

  6. mikesoto
    Member
    Posted 1 year ago #

    I just installed this plugin and getting the same results in IE8 and Firefox. Does anybody have a solution?

  7. germanny
    Member
    Posted 1 year ago #

    I installed this plugin the other day and I'm seeing a similar issue. On initial page load, the captcha plugin isn't displayed and it seems neither the image nor text file are created in the directory.

    However, after clearing the browser's cache, the image then appears and refreshes correctly.

    Kinda odd. Anyone have thoughts on what the problem could be?

    Thanks!

  8. lmilesw
    Member
    Posted 1 year ago #

    On some of my sites the captcha image disappeared after updating to WP 3.5. I use Gravity forms and had to revert back to reCaptcha as I could not find where the issue was. I tried deactivating all other plugins to no avail. The image only doesn't show when I am not logged into the site.

  9. germanny
    Member
    Posted 1 year ago #

    My issue ended up being WP Super Cache plugin. Once I added the form's page to the list of skipped URLs (on the Advanced tab, about halfway down - can't remember exactly what it's called), that fixed my problem.

  10. Pyxze
    Member
    Posted 1 year ago #

    I was having issues with this as well and noticed an error in the access logs saying that the .htaccess file (generated by the plugin in /uploads/wpcf7_captcha) wasn't readable.

    Changed permissions for the .htaccess file to 644 and the issue was solved.

  11. breeze76
    Member
    Posted 1 year ago #

    I had the same problem and did what Pyxze suggested and BINGO! it works...

  12. pawelpoz
    Member
    Posted 1 year ago #

    Try edit file: wp-content/uploads/wpcf7_captcha/.htaccess

    Then replace text with:

    Order Allow,Deny
    <FilesMatch "^[0-9A-Za-z]+\.(jpe?g|gif|png)$">
    Allow from all
    </FilesMatch>

    It works for me.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic