WordPress.org

Ready to get started?Download WordPress

Forums

Really Odd Redirect Issue (8 posts)

  1. olikid
    Member
    Posted 5 years ago #

    Hi there,

    I was hoping someone might be able to help.

    I'm having a really odd redirect issue on my site (here - soundmobiles.com)...

    See, I moved things around a bit recently - changed the site structure entirely, added a new theme, trying to get the general structure a little tidier really. It's an old site and I'm sure I'll have lost backlinks as a result but it had to be done.

    See, if you look at the categories to the left, when you clock on the Samsung category, you get a 404. On Sony Ericsson and a few others you get taken to individual posts rather than the category archive template - It's a really odd situation and I'm having real issues fixing it.

    I've looked through the DB but couldn't see anything particularly obvious about why it would happen - I checked the .htaccess file too - nothing.

    So - has anyone had experience of changing their site's structure and seen anything like this?

    Any suggestions at this stage are more than welcome as the longer it says like this the more 404's I'll be serving visitors.

    Cheers in advance.

  2. olikid
    Member
    Posted 5 years ago #

    Just wondering if anyone might be able to help with this?

    I'm still having no luck at all...

    Can't see anything in the DB, or the .htaccess file that might be causing this, so really I'm completely stumped.

  3. t31os
    Member
    Posted 5 years ago #

    It's due to a typo in the Samsung link...

    http://www.soundmobiles.com/phones/samsumg/

    Notice /samsumg/

    If i change the URL to the correct spelling it works... ;)

  4. olikid
    Member
    Posted 5 years ago #

    Ah, haha - I hadn't noticed that...

    It's odd though - that list is dynamically generated so really not sure why there's the issue - I've checked the WP back-end, and the category *is* spelt samsung... Really really odd.

    And then there's the issue of the other categories redirecting to individual posts - Again, checked the BD, and just can't work out why it's happening. Maybe I could try deleting then re-upping the posts?

    All around, very confusing.

  5. olikid
    Member
    Posted 5 years ago #

    All the 404's are fixed, but this Redirect issue is still completely stumping me.

    Can *anyone* offer any advice here?

  6. s_ha_dum
    Member
    Posted 5 years ago #

    Seems like a function of how the theme processes categories to me. What theme are you using?

  7. olikid
    Member
    Posted 5 years ago #

    It was originally based on Crafty Cart, but it's been pretty heavily modified since then.

    I don't get the issue when I have SEO friendly URL's switched off, only when I try to tidy the URL structure up - I've checked the .htaccess and can't see anything, I'm using custom caregory pages but they work fine on other WP installations I've got running.

    So yeah, just completely stuck at this stage.

  8. loveglass
    Member
    Posted 4 years ago #

    hi.
    could tell me how did you change your getshopped url in to your domain url?
    Thank you
    http://www.love-glass.co.uk

Topic Closed

This topic has been closed to new replies.

About this Topic