WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] reading posts (13 posts)

  1. rzamith
    Member
    Posted 6 years ago #

    Hi guys,

    I'm new at WordPress, still learning how to use it!

    But there's one thing confusing me: I have a theme that summarizes me the posts on the main page. But when I click on one post to read it, WordPress doesn't open it - it just redirects me to the same "main page" of the blog.

    Can anybody tells me why is this happening?

    Thanks!

  2. Kalessin
    Member
    Posted 6 years ago #

    Not without looking at the page...

  3. rzamith
    Member
    Posted 6 years ago #

    Kalessin,

    What do you suggest I do?
    Do you want me to post here a specific part of the code?

    Thanks.

  4. Jeremy Clark
    Moderator
    Posted 6 years ago #

    Yes paste the contents of the main index template to http://wordpress.pastebin.ca and report the link back.

  5. rzamith
    Member
    Posted 6 years ago #

    Are you talking about «index.php» located in the folder wp-content?

  6. Jeremy Clark
    Moderator
    Posted 6 years ago #

    It's the index in your current theme in the wp-content folder.

  7. rzamith
    Member
    Posted 6 years ago #

    My index.php has the following text:

    <?php
    // Silence is golden.
    ?>

  8. Jeremy Clark
    Moderator
    Posted 6 years ago #

    It's the index in your current theme in the wp-content folder.

    Sometimes it's also called main.php.

  9. rzamith
    Member
    Posted 6 years ago #

    My friend, here it is:

    http://wordpress.pastebin.ca/905103

    Altough I think the problem also happens with the other themes, even with WP Classic.

  10. Jeremy Clark
    Moderator
    Posted 6 years ago #

    I see nothing wrong with that. Have you tried updating your permalinks. Also a link to the page this is happening on would also be very good.

  11. rzamith
    Member
    Posted 6 years ago #

    I've changed my permalinks, and it has worked on the classic theme. Still doesn't work on my actual theme. Now, it opens a new blank page.

    Please check it here (still a temporary address).

  12. rzamith
    Member
    Posted 6 years ago #

    Jeremy,

    DONE IT! hehe I've replaced the theme for the same one, but with no editing on it.

    Thanks for the help.

  13. Kalessin
    Member
    Posted 6 years ago #

    I actually meant you to post a link to the page, but I'm pleased to see you've solved the problem anyway :)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.