WordPress.org

Ready to get started?Download WordPress

Forums

"Read More.." not working. (10 posts)

  1. noshowmojo
    Member
    Posted 5 years ago #

    Hi

    So I want to show just excerpts on the main blog page ok.

    I've read about two ways to do this

    1)
    <?php the_content('Read More...'); ?>

    This doesn't seem to do anything for me.

    2)
    <?php the_excerpt(); ?>

    This cuts off the full length of the post but it just shows a nasty little [...] with no clickable link at the end.

    So I've tried changing to:

    <?php the_excerpt('Read More...'); ?>

    But still just the nasty [...]

    Help please.

  2. Chris_K
    Member
    Posted 5 years ago #

    Your option 1 won't work unless you also add the more tag to the posts (it's a button in the post editor).

    You might also want to check out Customizing_the_Read_More in the Docs section.

  3. noshowmojo
    Member
    Posted 5 years ago #

    Thats brilliant. Thanks!

  4. com3
    Member
    Posted 5 years ago #

    holy win! i started trying to rewrite all kindsa stuff only to realize that there was a !---more---- tag! hahaha! thanks a ton!

  5. inspiremedia
    Member
    Posted 5 years ago #

    Ok, I have been searching around for hours for a solution. I am using the < 1--more-- > tag in my article post and it is working properly. However, the read more link does not show up. I know it is my theme that I am using that is causing the problem, but how can I resolve the problem without changing the theme. I have added all kinds of code, but it still does not work. The website is http://www.contagiouschiropractic.com.

  6. yetimade
    Member
    Posted 4 years ago #

    Hey, I had the same problem as noshowmojo only, when I use the <!--more--> tag either manually or in the WP pannel, it does not work. What am I doing incorrectly?

  7. Shane G.
    Member
    Posted 4 years ago #

  8. dragonsjaw
    Member
    Posted 4 years ago #

    And I just saw this today:
    digwp.com/2010/01/wordpress-more-tag-tricks/

    Lots of good info for the more tag

  9. samuelpage
    Member
    Posted 4 years ago #

    Hey All,

    This is probably because you've got the posts returning on a page, rather than the default index which is just returning posts.

    By default the 'read more' link is disabled on a page, so you have to set the variable to enable it, change:

    <?php the_content('Read the full article...'); ?>

    to

    <?php
    global $more;
    $more = 0;
    the_content('Read the full article...');
    ?>

    Hope that helps!

  10. jimisdon
    Member
    Posted 4 years ago #

    samuelpage,
    Thank you. I just started looking for an answer to this problem, and it was looking like I had a long night ahead of me. Glad you responded to this thread.

Topic Closed

This topic has been closed to new replies.

About this Topic