WordPress.org

Ready to get started?Download WordPress

Forums

Testimonials by Aihrus
[resolved] Read More Link Not Showing (24 posts)

  1. ChrisFord
    Member
    Posted 1 year ago #

    I just installed the premium plug-in today and added the widget to my sidebar.

    The site URL is http://www.myfordassociates.com

    The "Read More" link does not display in the widget. I can't figure out if I'm doing something wrong or not. Please take a look and advise.

    Best,
    Chris Ford

    http://wordpress.org/extend/plugins/testimonials-widget/

  2. ChrisFord
    Member
    Posted 1 year ago #

    Update - The widget doesn't seem to work.

    I made no changes at all. I just went back to my site, and the widget has stopped rotating.

    I clicked on the Next Testimonial link - nothing happened. It just sits there on one testimonial.

    I would appreciate some input. This is pretty frustrating!

  3. Michael Cannon
    Member
    Plugin Author

    Posted 1 year ago #

    1. It's not going to rotate if there's only one testimonial.

    2. There's not going to be a "Read more" link when there's no extra text to display. You only have an excerpt it appears from http://myfordassociates.com/testimonial/john-salisbury/.

  4. ChrisFord
    Member
    Posted 1 year ago #

    I have around 15 or so testimonials posted. Most are well over 150 characters.

    https://myfordassociates.com/testimonial/

    The widget isn't working.

  5. ChrisFord
    Member
    Posted 1 year ago #

    When it was actually rotating (it worked when I first added the widget), it never showed a Read More link, and the Next Testimonial link didn't do anything when it was visible.

  6. ChrisFord
    Member
    Posted 1 year ago #

    Oh wait... you're saying it's only showing the excerpts? I will look at that.

  7. Michael Cannon
    Member
    Plugin Author

    Posted 1 year ago #

    In the HTML, there's only one testimonial. Are you using limit=1 someplace? How about a combination of tags and categories?

    Why don't you try deleting and then adding a fresh Testimonials Widget widget instance.

  8. ChrisFord
    Member
    Posted 1 year ago #

    I checked Hide Excerpt? but it's still the same. I also changed the rotation speed to 3. Still not rotating.

  9. ChrisFord
    Member
    Posted 1 year ago #

    OK let me try that.

  10. ChrisFord
    Member
    Posted 1 year ago #

    OK it's scrolling but still no Read More link. I must be doing something wrong. I couldn't find instructions anywhere.

  11. ChrisFord
    Member
    Posted 1 year ago #

    Here's a link to a screen shot of my settings. I couldn't find user documentation that explains what all the fields are. If one exists, it may solve my problem.

    Here are my settings: http://myfordassociates.com/wp-content/uploads/2013/02/testimonials.png

    I was really confused by the Premium Options Maximum Length. I entered 150 there. It seems that field actually filters the testimonials and won't show a testimonial over the max. I cleared that field, then checked the field to hide the excerpt. When I did that, it started rotating again.

    I set the Character limit field to 150, which seems to work properly. Now, the widget is truncating at 150 characters, the way it should.

    Still, no Read More link, though. Is there another check box I should have checked in order to get it to display?

  12. ChrisFord
    Member
    Posted 1 year ago #

    I discovered that the Read More link IS actually on my page - It's actually showing up on the left side toward the bottom of my website (which is not a sidebar, either). It's like the Read More just wrapped outside the widget in the right sidebar and ended up across the page. I wonder if this issue might be related to the one that peterash is reporting.

    See screen shot.

    http://myfordassociates.com/wp-content/uploads/2013/02/readmore.png

    Notice the Read More link on the bottom left side. It's formatted as red, bold underlined, which is how my child theme formats read-more links seemingly.

    I'm using Genesis with a child theme. Their stuff seems to be compatible with just about anything, so I'm pretty surprised to see this. Given peterash is having a problem with the content spread outside the widget, I'm guessing mine is the same problem.

  13. Michael Cannon
    Member
    Plugin Author

    Posted 1 year ago #

    CSS issue resolved in prior thread.

    Nice work figuring out that your options were preventing more than one testimonial from showing up.

  14. ChrisFord
    Member
    Posted 1 year ago #

    I'm not sure how this could be even remotely considered resolved. The problem hasn't gone away. I bought the premium widget specifically for this purpose, and it doesn't work. I'm not a programmer - hence I bought a widget. I have no idea what you mean when you say "CSS resolved it." What does that mean? What am I supposed to do?

  15. Michael Cannon
    Member
    Plugin Author

    Posted 1 year ago #

  16. ChrisFord
    Member
    Posted 1 year ago #

    @ChrisFord, .more-link is display: block; You might try the following to fix.

    . testimonialswidget_testimonial .more-link {
    display: inline;
    }
    For you and others, weird presentation issues like this are almost always related to theme CSS. Use your browsers right-click Inspect Element option to trouble-shoot.

    Where do I put this code? Do I add it to the following? Am I supposed to change display: block to display: inline in the code below?

    I copied and pasted the above code and placed it directly above what's shown below. That did nothing. I left the code there, but changed display: block to display: inline. That did nothing. I removed the above code and left display: inline. Still no change. I will gladly insert whatever code is needed, but I need to know where it goes. This might as well be Chinese to me. I have no idea what I'm looking at.

    .more-link {
    border-bottom: 5px solid #d05353;
    bottom: -53px;
    color: #d05353;
    display: block;
    font-family: Verdana, Arial, Tahoma, sans-serif;
    font-size: 9px;
    font-weight: bold;
    left: 0;
    padding: 0 0 8px;
    position: absolute;
    text-align: center;
    text-decoration: none;
    text-transform: uppercase;
    width: 120px;
    z-index: 100;

  17. Michael Cannon
    Member
    Plugin Author

    Posted 1 year ago #

    At the bottom of your theme's style.css file, put the following CSS.

    q a.more-link {
    	display: inline;
    	position: relative;
    }

    Once you've force reloaded your browser cache, the Read More link should be at the bottom of the widget. Then, from here you can begin to debug its placement and styling by overriding the .more-link properties as you've originally defined above from your style.css file.

  18. ChrisFord
    Member
    Posted 1 year ago #

    That didn't change anything either. Maybe your plug in isn't compatible with Genesis framework?

  19. ChrisFord
    Member
    Posted 1 year ago #

    I contacted StudioPress, the developer of the Genesis framework and child theme that I am using on my site. I modified the style.css and it's working now.

    Thanks.

  20. Michael Cannon
    Member
    Plugin Author

    Posted 1 year ago #

    What was the solution that you needed?

  21. ChrisFord
    Member
    Posted 1 year ago #

    Modified .more-link in style.css. The style sheet causes your more.link to appear the same as the rest of the site. So, I modified the style to fit everything.

  22. Michael Cannon
    Member
    Plugin Author

    Posted 1 year ago #

    Ah, I see from your CSS file, http://myfordassociates.com/wp-content/themes/balance/style.css?ver=1.9.1, that you put the code I provided just below the original .more-link definition.

    I'm glad this worked for you.

    I've thought about adding the .hentry and .more-link CSS adjustments to the plugin's CSS file, but as the stylesheet is included before the theme's, it'd be futile.

  23. ChrisFord
    Member
    Posted 1 year ago #

    When I inserted this code:

    q a.more-link {
    display: inline;
    position: relative;
    }

    at the bottom of the style.css, nothing happened, which is why I felt the widget isn't compatible with Genesis or more specifically, my particular child theme.

    So I contacted StudioPress to find the code that needed to be changed. She told me that putting the code at the end wouldn't do anything, but suggested I insert that code in the content section of the css.

    Inserting the code into the content section moved the Read More link into the Testimonials Widget, but it was appearing under everything - It was under the source and company, and was still formatted the same way all of the other more.links were formatted on the site.

    In order to get the Read More link to appear directly after the truncated testimonial, I had to change the formatting of the .more-link

    The Balance child theme style.css formats the .more-link as follows:

    .more-link {
    border-bottom: 5px solid #d05353;
    bottom: -53px;
    color: #d05353;
    display: block;
    font-family: Verdana, Arial, Tahoma, sans-serif;
    font-size: 9px;
    font-weight: bold;
    left: 0;
    padding: 0 0 8px;
    position: absolute;
    text-align: center;
    text-decoration: none;
    text-transform: uppercase;
    width: 120px;
    z-index: 100;

    I modified the style as follows:

    .more-link {
    color: #d05353;
    display: inline;
    font-family: Verdana, Arial, Tahoma, sans-serif;
    font-size: 9px;
    font-weight: bold;
    left: 0;
    text-decoration: none;
    text-transform: uppercase;
    width: 120px;
    z-index: 100;
    }

    Once I got the link to appear in the widget, I just needed to decide how I wanted to format the .more-link site-wide. Then it took a little guess work to understand what all of the formatting was about. In the end, I think it worked out nicely.

    I'm sure for a designer, this is just part of a normal day's work. With probably millions of bloggers in the world today, creating their own blogs, I'd imagine that most of us are not designers. When I bought this plug-in, I thought it would be a simple plug-n-play, but as I often learn, not much in the world of blogging is really that simple.

  24. Michael Cannon
    Member
    Plugin Author

    Posted 1 year ago #

    Thank you very much for the response. Getting feedback like this helps me see other points of view so that I can try to provide better documentation and experience.

    Also, the next time someone asks a simliar question, I can point them here and they learn, not only solve the problem.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic