WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] "Read More" Excerpt help, not showing up in right location (10 posts)

  1. carterruss
    Member
    Posted 2 years ago #

    So I have my blog located here: http://breaktobuild.com/index/blog

    The issue is that my read more tags are coming after the complete post essentially. Even when I had the page break in the editor, they still show up at the bottom.

    Any one know what might be causing this?

  2. vjpo
    Member
    Posted 2 years ago #

    If you want to control where to break the post by 'more' tag, you have to
    edit the loop.php of your theme and change strings 28-29 (originally)

    <?php the_excerpt(); ?>
    <a class="read-more" href="<?php the_permalink() ?>">Read More ...</a>

    to
    <?php the_content('Read More...'); ?>

    You can edit this file in Appearance > Editor
    Read more about the Read More before editing )
    http://codex.wordpress.org/Function_Reference/the_content
    http://codex.wordpress.org/Template_Tags/the_excerpt
    http://codex.wordpress.org/Customizing_the_Read_More

  3. carterruss
    Member
    Posted 2 years ago #

    So I tried this and to no avail it didn't work. It wasn't doing this before I installed some plugins. The only plugin, that I can seem to think it may be, is my GD Star Rating, which is the only thing that doesn't show up before the current "read more". When I deactivate it however, it doesn't go away. Could this plugin somehow be the problem?

  4. alchymyth
    The Sweeper & Moderator
    Posted 2 years ago #

    are you using the manual excerpt for your posts?

    the 'read-more' link is hard-coded into loop.php of your theme so it will show independantly on your exerpt length and if you are using the 'more-tag'.

    <a class="read-more" href="<?php the_permalink() ?>">Read More ...</a>

    have you edited the loop.php template in any way?

  5. carterruss
    Member
    Posted 2 years ago #

    This is my current loop.php:

    [code moderated per forum rules - please use the pastebin]

    I haven't edited it. Would, I also need to change something in the blog.php? I'm fairly new with wordpress so my knowledge is mediocre at best.

  6. alchymyth
    The Sweeper & Moderator
    Posted 2 years ago #

    blog.php has the same two lines of code - the excerpt and the hard-coded 'read more' link:

    <?php the_excerpt(); ?>
          <a class="read-more" href="<?php the_permalink() ?>">Read More ...</a>

    the full post content should not show unless you have added it into the manual excerpt field.

    do you have any plugins activated?

  7. carterruss
    Member
    Posted 2 years ago #

    These are all the plugins I have:

    All in One SEO Pack
    byBrick Columns
    Datafeedr Random Ads V2
    GD Star Rating
    Sharebar
    Social Login
    TinyMCE Advanced
    ViperBar
    WP MashSocial Wigdet
    WP to Twitter

  8. vjpo
    Member
    Posted 2 years ago #

    Yes, I haven't noticed that in blog.php also the same lines 47-48

    <?php the_excerpt(); ?>
    <a class="read-more" href="<?php the_permalink() ?>">Read More ...</a>

    Did you try to edit it?

  9. carterruss
    Member
    Posted 2 years ago #

    So I figured out the issue, it was my Cincopa plugin. Thank you for all the help, learned about the excerpt and content tags in the mean while :)

  10. djwhite
    Member
    Posted 1 year ago #

    I'm having the same problem and do not see loop.php in my theme.
    http://debradjwhite.com
    Thanks in advance for your help!
    Joy, DJ

Topic Closed

This topic has been closed to new replies.

About this Topic