WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Read more doesn't work in new blog template (3 posts)

  1. mark-ter-s
    Member
    Posted 1 year ago #

    I created a new page template for my blogposts, everything works perfectly except for the read more tag, i can see the <!--more--> tag in the post editor but when posted, the site shows the whole message. Can anybody tell me what is missing in my code?

    I really hope someone can help me

    Here's the code from the page

    <?php /* Template Name: Blog */ ?>
    
    <?php get_header() ?> 
    
    	<div id="content">
    
    	<?php locate_template( array( 'leftsidebar.php' ), true ) ?>
    		<div class="padder three">
    
    		<?php do_action( 'bp_before_blog_home' ) ?>
    
    		<?php do_action( 'template_notices' ) ?>
    
    		<div class="page" id="blog-latest" role="main">
    
    		<?php query_posts ($query_string . '&cat=45'); ?>
    
    		<br><?php if ( have_posts() ) : ?>
    
    			<?php bp_dtheme_content_nav( 'nav-above' ); ?>
    
    <?php
    $temp = $wp_query;
    $wp_query= null;
    $wp_query = new WP_Query( 'cat=45' );
    $wp_query->query('posts_per_page=5'.'&paged='.$paged.'&cat=45');
    while ($wp_query->have_posts()) : $wp_query->the_post();
    ?>
    
    					<?php do_action( 'bp_before_blog_post' ) ?>
    
    					<div id="post-<?php the_ID(); ?>" <?php post_class(); ?>>
    
    						<div class="author-box">
    							<?php echo get_avatar( get_the_author_meta( 'user_email' ), '50' ); ?>
    							<p><?php printf( _x( 'by %s', 'Post written by...', 'buddypress' ), bp_core_get_userlink( $post->post_author ) ) ?></p>
    
    							<?php if ( is_sticky() ) : ?>
    								<span class="activity sticky-post"><?php _ex( 'Featured', 'Sticky post', 'buddypress' ); ?></span>
    							<?php endif; ?>
    						</div>
    
    						<div class="post-content">
    							<h2 class="posttitle"><a href="<?php the_permalink() ?>" rel="bookmark" title="<?php _e( 'Permanent Link to', 'buddypress' ) ?> <?php the_title_attribute(); ?>"><?php the_title(); ?></a></h2>
    
    							<p class="date"><?php printf( __( '%1$s <span>in %2$s</span>', 'buddypress' ), get_the_date(), get_the_category_list( ', ' ) ); ?></p>
    
    							<div class="entry">
    								<?php the_content( __( 'Read the rest of this entry →', 'buddypress' ) ); ?>
    								<?php wp_link_pages( array( 'before' => '<div class="page-link"><p>' . __( 'Pages: ', 'buddypress' ), 'after' => '</p></div>', 'next_or_number' => 'number' ) ); ?>
    							</div>
    
    							<p class="postmetadata"><?php the_tags( '<span class="tags">' . __( 'Tags: ', 'buddypress' ), ', ', '</span>' ); ?> <span class="comments"><?php comments_popup_link( __( 'No Comments »', 'buddypress' ), __( '1 Comment »', 'buddypress' ), __( '% Comments »', 'buddypress' ) ); ?></span></p>
    						</div>
    
    					</div>
    
    					<?php do_action( 'bp_after_blog_post' ) ?>
    
    				<?php endwhile; ?>
    
    				<?php bp_dtheme_content_nav( 'nav-below' ); ?>
    
    			<?php else : ?>
    
    				<h2 class="center"><?php _e( 'Not Found', 'buddypress' ) ?></h2>
    				<p class="center"><?php _e( 'Sorry, but you are looking for something that isn\'t here.', 'buddypress' ) ?></p>
    
    				<?php get_search_form() ?>
    
    			<?php endif; ?>
    		</div>
    
    		<?php do_action( 'bp_after_blog_home' ) ?>
    
    		</div><!-- .padder -->
    	</div><!-- #content -->
    
    	<?php get_sidebar() ?>
    
    <?php get_footer() ?>
  2. alchymyth
    Forum Moderator
    Posted 1 year ago #

    could be caused by this being a page template;

    review http://codex.wordpress.org/Customizing_the_Read_More#How_to_use_Read_More_in_Pages

  3. mark-ter-s
    Member
    Posted 1 year ago #

    Putting

    global $more;$more = 0;

    within the loop did the job!
    thanks!

Topic Closed

This topic has been closed to new replies.

About this Topic