WordPress.org

Ready to get started?Download WordPress

Forums

BirdFLAT
read more (8 posts)

  1. akirakin71
    Member
    Posted 1 year ago #

    Hello.

    I just wanted to know how to put "read more" when I place a page break in my blog.
    At the index page, "Read more" appears when I do not place an page break,
    but when I do, nothing appears, and I want my readers to know that there are more to read in a single post.

    While I am on the subject,
    is there a way I can set how much words the index page can show?
    I see that there are "excerpt" coded, but I couldn't figure out how it was determining how many words to show.

    By the way, I really do like the theme.
    Great work.

  2. Evan Herman
    Member
    Posted 1 year ago #

    The excerpt is probably declared inside of the functions.php file. There you can determine how many letters to filter through

  3. akirakin71
    Member
    Posted 1 year ago #

    Evan,

    Thank you for the advice.
    I am not proficient at reading php, but will try anyway.

    Thanks.

  4. preethamchandra
    Member
    Posted 1 year ago #

    If your requirement is to have control on Excerpt. let me know i think i can help

  5. akirakin71
    Member
    Posted 1 year ago #

    Preethamchandra,

    actually, what I need is to have control over displaying "read more" on page breaks. Having control on excerpt would be my second way of doing things. I would like to know what you can help me with though, so I do have a back up in case nothing else works.

  6. preethamchandra
    Member
    Posted 1 year ago #

    I haven't worked with page breaks.

    Here is what you can do.

    Insert <!--nextpage--> to add page breaks

    Read here for more
    http://codex.wordpress.org/Template_Tags/wp_link_pages

    --

    Mean while you can try this.

    Add below code in functions.php

    This will control the lenght of text on front page posts.

    -------------------
    function my_excerpt_length($length) {
    return 30;
    }
    add_filter('excerpt_length', 'my_excerpt_length');

  7. akirakin71
    Member
    Posted 1 year ago #

    preethamchandra,

    thank you for the excerpt code.
    I will try it ASAP.

  8. akirakin71
    Member
    Posted 1 year ago #

    I have solved the problem, sort of, but not with functions.php.
    My WP is in Japanese, so it has a plugin to fix double bite word codes called "WP Multibyte patch".
    There are configs in that lets me adjust the excerpt length.

    "Read more" still does not appear when I place page breaks in the posts, but I am satisfied with this setting, so the first problem I have is no longer a problem.

    If the theme creator could help in the page break and "read more" settings, it would be greatly appreciated.

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic