WordPress.org

Ready to get started?Download WordPress

Forums

RE: list of working plugins in WP2.1alpha2 (19 posts)

  1. yosemite
    Member
    Posted 8 years ago #

    Somebody (spence?) requested feedback on what plugins were working in WP2.1alpha2, even supplied a link to submit, but I can't find it now...

    Working for me:
    Akismet 1.15
    Bad Behavior 2.0.1
    CoolPlayer 8.3
    Admin Autumn 1.2
    Angsuman's Feed Copyrighter 1.0
    Download Manager R1.beta2_WP2
    Dagon Design Form Mailer 4.1
    Diagnosis 1.1
    Favatars 2
    FD Feedburner Plugin 1.0
    Hot Dates 1.0
    Hello Dolly 1.5
    ImageManager 2.3.7
    Live Comment Preview 1.7
    Lightbox 2.0 Plugin 0.6 Final
    My comments 0.1
    Sociable 1.2
    Translate 1.0 (Trevor Creech)
    WP-ShortStat 1.3 (with 2.0 fix)
    About Me widget 0.95
    Joe's Quotes Widget 1.1

    I haven't tested extensively but all appear to function without error...

    Confirmed problem:
    Get Recent Comments 1.2 (Author is aware of problem [using GLOBALS], hasn't updated yet)

  2. spencerp
    Member
    Posted 8 years ago #

    Thanks for your list Sam.. =) I spent the one night, fixing this plugin's globals, as far as I know, it's working just fine. =)

    Demo On My 2.1 alpha2 test blog:
    http://212.vindictivebastard.net/

    Copy of the "working" Get Recent Comments for 2.1 alpha2:
    http://212.vindictivebastard.net/plugin-txt/get-recent-comments.php.txt

    I even posted about the fixes and such on the Plugin Author's blog, on the Recent Comments post. =)
    http://blog.jodies.de/archiv/2004/11/13/recent-comments/#comment-90351

    http://blog.jodies.de/archiv/2004/11/13/recent-comments/#comment-90352

    http://blog.jodies.de/archiv/2004/11/13/recent-comments/#comment-90354

    Of course, I didn't hear any word on it yet or whatever.. but, that's up to he/she I guess lol. Thanks again for your list Sam, I'll have to get to work on updating the list then sigh.. Just been busy lately.. :(

    Codex list for those working plugins on 2.1 alpha2, that I started up a while ago:
    http://codex.wordpress.org/User:Spencerp/2.1alpha1_Plugin_Compatibility

    spencerp

    Yeah, I know.. no Alpha discussion on here lol, just this was posted already, and I wanted to add my 2 cents to it lol! =p

    Also, props goes to Jeremy Visser on updating my Codex page, removed the ROUGH DRAFT part of it and updated the URL of it as well. =) ;)

  3. spencerp
    Member
    Posted 8 years ago #

    Also to add on this quick, these came through the wp-testers list before, but I can't find the posts in there sigh. This was from Craig (aka NuclearMoose)

    "
    Akismet 1.15-wo
    Adhesive 3.2
    Extended Live Archives 0.10beta-r18 Not activated but tested and seems to work.
    Brian's Latest Comments 1.5.8
    Bad Behavior 2.0.1
    Custom Query String 2.7
    DoFollow 2.0
    Democracy 1.2
    Geo 1.0
    Gravatars 2.6
    Installer 0.4
    Link Footnotes 1.1
    Log 404 1.2.1
    Live Comment Preview 1.7
    Links Page 1.0
    More Unique R1
    CJD Notepad 1.5.5.2
    No Ping Wait 2.0
    Subscribe To Comments 2.0.2
    SRG Clean Archives 1.5
    SVN Update 0.1
    Ultimate Tag Warrior: Tag Archive 1.0
    Ultimate Tag Warrior 3.14
    WordPress Database Backup 1.7
    WP-ContactForm 1.4.3
    Sidebar Widgets 1.0

    AFAIK the above plugins seem to be working just fine with the latest SVN version installed and upgraded."

    And this also came through the list from JoeyFish:

    I can add to that:

    Audio player 1.2.2
    Akismet Spam Count 1.1
    Browser Sniff 1.7
    FeedBurner Awareness 1.1
    Feedburner Feed Replacement 2.0.2
    Kip Bond's Gravatars2 v2.5.0
    Google Analyticator 1.4
    Impostercide 1.2
    IP 2 Nation 1.1
    Permalink Redirect 0.6.0
    Post Levels 1.0
    Quick Stats 1.0
    Subscribe To Comments 2.0.4
    Trackback Validator 0.7.1
    Trackping Separator 1.0.6a
    Ultimate Google Analytics 1.4
    Unfancy Quote 2.0
    WordCount 0.1
    WordPress Reports 0.52
    WP-Microsummary 0.9
    WP-PageNavi 2.0.2
    WP-phpMyAdmin 2.8.2
    Markus Kaemmerer's WP-ShortStat 1.11
    WP-Stats 2.0.4

    Also, turk has his plugin's used listing his current working plugins on his 2.1 alpha2 blog currently:
    http://www.hotelblues.com/plugins-used/

    I *really* have to update my list soon, and very soon sigh.

    spencerp

    Sorry moshu, I know you hate the discussions of the Alphas in here, but I really wanted to share this list with Sam quick..since he already posted on it before. =) ;)

    Also, this is *only* a plugins list, not issues and support related issues with the Alpha.. all our support requests and help needed requests, will be posted to the wp-testers list of course. ;)

  4. yosemite
    Member
    Posted 8 years ago #

    Yup, all my fault. I'm baaaad. Somewhere kittens are dying.

  5. spencerp
    Member
    Posted 8 years ago #

    Yup, all my fault. I'm baaaad. Somewhere kittens are dying.

    LOL! Nah, it's not *really* that bad..I don't think..because were not asking for support and such for it here.. But, I dunno though...it's just a very thin sheet of ice, mentioning the Alphas here..sigh.

    I just wish there was a forum specifically for discussion of it though, because everyone will be *lost*, when it's finally released... They should *all* get a taste of it now though, ahead of time..

    Because the way the backend is now setup for "link management" and stuff..is quite confusing..I was even a little lost at first, with the latest changes sigh.. Oh well.. when the time comes.. ppl will see. ;) :)

    spencerp

    I was saying the above because of what moshu had said in this thread before.. =/

  6. Lester Chan
    Member
    Posted 8 years ago #

    spencer: try my plguin and update it when ya free =D

  7. spencerp
    Member
    Posted 8 years ago #

    spencer: try my plguin and update it when ya free =D

    Hahaha!...I sure will try them all..and see what happens lol! ;)=) Can't promise too much though haha, you're the "King of your own Plugins".. =P

    spencerp

  8. _ck_
    Member
    Posted 8 years ago #

    Can you identify in general what *might* cause a plugin to break under 2.1 vs 2.0.x ?

    There aren't any database layout changes in 2.1 correct, just additional options for some fields?

    ie. "future" for the post status is new in 2.1 but the field data type is identical so it shouldn't break anything unless it's poor code that doesn't know what to do with an unknown setting (or interprets it wrong)

  9. spencerp
    Member
    Posted 8 years ago #

    _ck_, a number of stuff has been change for 2.1 vs 2.0.4 as far as I know.. example: file paths and file changes..

    The backend is different, and as far as I know, there was some database changes too. =/ But, since were not allowed to talk about the Alpha(s)/support and tech end of it, in here.. you should post this to the wp-testers list.

    They'll be able to specify more, what's different between versions. ;) Good luck, and I'll reply to your comment on my 2.1 alpha2 blog then. ;)

    spencerp

  10. Mark (podz)
    Support Maven
    Posted 8 years ago #

    There are database changes.
    I don't know what but recently 3 plugins I ran broke (Comment plugger, recent posts, recent comments).
    Anyway, if you are running a plugin and it's not on the list and you'd like it checking, let us know :)

  11. spencerp
    Member
    Posted 8 years ago #

    Ok, thanks to Yosemite's (Sam Devol's) awesome preformatted text/link setup.. like I need lol.. I rushed right through updating my Codex page just now. =)

    http://codex.wordpress.org/User:Spencerp/2.1alpha2_Plugin_Compatibility

    With what he gave me, the following sections have been updated. =)

    A-C Section
    D-F Section
    G-K Section
    L-O Section
    P-S Section
    T-V Section
    W-Z Section

    I also had added some the other night..so, hopefully..people can send me their plugins in a format like such.. so I can add them so much quicker.

    Example: <a href="http://www.coolcode.cn/?p=100">CoolPlayer 8.3</a>

    Also! If you want too..I started up a 2.1 Plugin Mailing List.. (Using the same software, as the WP email lists..)

    I just figured, this might be a little better for those wanting to share ideas, about the "Working" and "Non-Working" plugins for WordPress version 2.1 alpha2.. and make it a little bit easier, at same time.

    I know the wp-testers list is here, as well as the wp-hackers list.. but, they discuss ALL ranges of things.. not just dedicated to the 2.1 plugins. So if you'd like, feel free to join that then. =)

    spencerp

  12. xinfo
    Member
    Posted 8 years ago #

    it will be better if you guys provide along with plugin link

  13. spencerp
    Member
    Posted 8 years ago #

    Ok peoples..I just spent that last how many God forsaken hours.. Googling and finding the links for the above Plugins.

    PLUS! The ones listed on this guy's blog, which is running 2.1 alpha2: http://www.hotelblues.com/plugins-used/

    Well, those that were not already provided by Yosemite (Sam)'s awesome link/text format lmao. Also, I need to know for sure.. where and what's the right links and information for the following plugins..

    Subscribe To Comments 2.0.2
    SRG Clean Archives 1.5
    SVN Update 0.1

    Well, I know who makes the SRG Clean Archives plugin, but.. I couldn't get runPHP to work on my first 2.1 test install.. so I couldn't run the SRG Clean Archives.. I need to know for sure.. what you used to get it running and such.

    I also need to know for sure, which plugin author's Subscribe To Comments you're talking about.. And, as for the SVN Update 0.1.. I couldn't find it period.. =/

    I'll need the URL for that one then too. Well, low and behold.. here is the updated page of mine now lol!

    2.1alpha2_Plugin_Compatibility Page

    If you're a Plugin Author, why not run and test the 2.1 alpha2, and add your plugins there.. =P I'm also thinking about, copying Matt's 2.0 Plugin Compatibility page to a Text file.. then just cut/copy paste into my page.. the ones that are working on 2.1 alpha2 hehe. =)

    Anyways.. this is what I got now.. =)
    2.1alpha2_Plugin_Compatibility Page

    spencerp

    Also, if you want to, please feel free to join my Mailing List for the 2.1 alpha2 plugins.

  14. spencerp
    Member
    Posted 8 years ago #

    Oh yeah! I did more link clicking and searching, than I ever did while porning.. Jesus Christ! And that's *alot* of clicking and searching!!.. lmao!!

    spencerp

  15. theoa
    Member
    Posted 7 years ago #

    spencerp:

    Many thanks for all the clicking and searching - it's appreciated...

  16. spencerp
    Member
    Posted 7 years ago #

    You're welcome. =) As far as I know, that list is ok, and updated.. =/ But, it really comes down to, others "testing/adding" new ones to that page.. cause, I just don't have the "time" now.. to do all this stuff sigh. =(

    spencerp

  17. spencerp
    Member
    Posted 7 years ago #

    Just to update everyone on things, my http://212.vindictivebastard.net/ 2.1 alpha3 Test blog, now redirects to the new location of: http://21.spencerp.net/

    So the new location for the Get Recent Comments, that works on the 2.1 alpha3, is now here. And my Codex Page has also been updated. Thanks!

    spencerp

  18. mattyrob
    Member
    Posted 7 years ago #

    I note from the Codex Page that Subscribe2 is listed as working.

    I took this plugin over from Skippy a while ago and I have amended the code in a branch ready for 2.1 - most things work as expected except furture posts and digest emails as these rely on WP-Cron.

    I've noticed that Cron is going into the main code, so where can I get some help on how to make it compatible?

  19. spencerp
    Member
    Posted 7 years ago #

    Just to update everyone on my 2.1 Plugin Compatibility page..

    It has now been moved to here:
    http://codex.wordpress.org/Plugins/Plugin_Compatibility/2.1

    For all others, here's the new link:
    http://codex.wordpress.org/Plugins/Plugin_Compatibility

    Also, my 21.spencerp.net site will be going down, or, be used as a redirect to the new 2.1 Plugin Compatibility Codex page.. ;) :)

    spencerp

Topic Closed

This topic has been closed to new replies.

About this Topic