WordPress.org

Ready to get started?Download WordPress

Forums

Re-installing over an older corrupted version of WP (6 posts)

  1. Dave333
    Member
    Posted 5 years ago #

    I have a blog that is using WordPress version 2.7 and it has become corrupted due to the use of Slickr's use of the function fopen, which is disabled on my host's server. I had been using Slickr for months and was only when I activated NEXTGen plugin that this problem arose. I've disabled both now but makes no difference the damage has been done.

    After many hours of struggling with the web host they have wiped their hands of the issue and told me I need to reinstall WordPress as simply restoring the database didn't work.

    So I have looked through the Codex and forums but can't find anything on this:

    How do I install the latest version of WordPress if I already have a corrupted and older version installed?

    i.e., Do I have to uninstall the corrupted version of WordPress first?

    Or do I install straight over the top by following the standard installation Codex instructions?

    Will my back up from an older verison of WordPress be able to be restored to the new installation?

    Or do I need to install 2.7 first and then upgrade to 2.7.1?

    I have already tried the automatic upgrade to 2.7.1 and it failed. Message gven was:

    Downloading update from http://wordpress.org/wordpress-2.7.1.zip

    Unpacking the core update

    Could not create directory: /public_html/website/blog/wp-content/upgrade/core

    Installation Failed

    It managed to write a few files to the wp-content/upgrade/core folder before failing so it doesn't appear to be a permissions issue with the folder.

    Any advice on where to go from here?

    Thanks.

  2. Samuel B
    moderator
    Posted 5 years ago #

    this makes no sense. what is corrupted about the database? that a re-install of wordpress would cure?
    wordpress is only files so if the db really is corrupted a re-install will not help ever.
    tell what is happening exactly. why you feel it is corrupted?

  3. Dave333
    Member
    Posted 5 years ago #

    It is not the database that is corrupted, hence why restoring the database don't fix the situation. It is the WordPress installation that is corrupted, according to my webhost, and needs to be reinstalled, as I described above.

    I have a good working backup of the database from before this problem arose so if I can get rid of the corrupted version of WordPress and install a fresh new working copy of the WordPress then I can restore the working back up of the database.

    Some of the symptoms:

    Trying to visit the blog in a browser will return a blank white page.

    I was able to log in to the admin section of my site. When I do I get a single line of code at the top of the page that says:

    Warning: array_keys() [function.array-keys]: The first argument should be an array in /home/webaccount/public_html/website/blog/wp-includes/widgets.php on line 1044

    However, I have just tried to log in to the admin section then and it seems to have gotten worse. Now all I get is a blank page with the following messages:

    Warning: array_keys() [function.array-keys]: The first argument should be an array in /home/webhostaccount/public_html/website/blog/wp-includes/widgets.php on line 1044

    Warning: Cannot modify header information - headers already sent by (output started at /home/webhostaccount/public_html/website/blog/wp-includes/widgets.php:1044) in /home/webhostaccount/public_html/website/blog/wp-includes/pluggable.php on line 850

    If reinstalling WordPress won't fix this what other options do I have?

  4. whooami
    Member
    Posted 5 years ago #

    Warning: array_keys() [function.array-keys]: The first argument should be an array in /home/webaccount/public_html/website/blog/wp-includes/widgets.php on line 1044

    thats not a file problem. thats a problem in your database. its also searchable.

    http://wordpress.org/search/Warning%3A+array_keys()+%5Bfunction.array-keys%5D%3A+The+first+argument+should+be+an+array+widgets.php?forums=1

    the very first response provides the answer.

    since the link above is broke, heres THAT thread:

    http://wordpress.org/support/topic/172272?replies=14

    Not to sound smug, but about the reinstalling business...

    wordpress isnt windows.

  5. Dave333
    Member
    Posted 5 years ago #

    Whooami,

    Thank you so much. I just went and deleted the wiget_text part of the db table and the blog works fine now.

    I have no idea what your referrence to Windows means, I am on a Mac.

    I spent many many hours on this and my blog was dead for days. With your help it was fixed in less than a minute.

  6. whooami
    Member
    Posted 5 years ago #

    I have no idea what your referrence to Windows means, I am on a Mac.

    Thats why youre on a mac, you just dont know it. :)

    windows is notorious for people just reinstalling to fix some small thing. sometimes thats easier.

    anyway, glad I helped.

Topic Closed

This topic has been closed to new replies.

About this Topic