WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Re-Installing for the SIXTH time! What am I doing wrong? (3 posts)

  1. JG99
    Member
    Posted 4 years ago #

    I have been struggling for the past two days with installing WordPress myself. When I upload the zip file directly, it goes into a subdirectory called /wordpress. Then my URL turns into "mysite.com/wordpress" rather than simply "mysite.com." Everyone says that if I simply install WordPress on the root directory, this problem will be eliminated. OK, fine - let's give it a shot. I have now unzipped the WordPress file (rather than upload the zip file directly) and have 3 folders on my desktop (wp-admin, wp-content and wp-includes) plus maybe 20 other individual files. How do I upload these to the root? I have FileZilla, but when opened it only shows the 3 folders named above, not the other 20 or so individual files.

    Here is what the options are in cPanel on the left side:

    (/home/username)
    access-logs
    etc
    mail

    cur

    new

    tmp
    public_ftp

    incoming
    public_html

    _private

    _vti_bin

    _vti_cnf

    _vti_log

    _vti_pvt

    _vti_txt

    cgi-bin

    images
    tmp

    analog

    awstats

    cpbandwidth

    webalizer

    webalizerftp
    www

    _private

    _vti_bin

    _vti_cnf

    _vti_log

    _vti_pvt

    _vti_txt

    cgi-bin

    images

  2. You can keep WordPress in the /wordpress folder and still have the blog 'act' as if it was in root (which, by the way, will help ensure compatibility with other web apps like a gallery or a wiki if you install those later).

    That said, all you have to do is copy all the files and folders from www/wordpress into www/ and it'll work fine.

  3. JG99
    Member
    Posted 4 years ago #

    This is how I solved the problem:

    Deleted my database in cPanel.

    Deleted wordpress files using cPanel file manager.

    At this point, "public_html" were empty. Deleted files _vti_inf.html and postinfo.html , and the directories cgi-bin, images and _vti_bin.

    Uploaded the ALREADY UNZIPPED wordpress files and directories (with their contents) to "public_html" using FileZilla.

    Then I followed the 5-minute install instructions on WordPress.org and now the blog is working perfectly and is in my root directory which means "www.mysite.com"

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags