WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Re: Image url path after moving sites (11 posts)

  1. leradstar
    Member
    Posted 1 year ago #

    Hi,
    I have read and think followed the steps to the book but can't get my blog.dir path correct.
    I made the site in a test site and then moved them to a new domain within the subfolder so I can make sure all goes well.
    My problem is in the blog.dir path
    Somehow the domain name is omitted. Checked the database thoroughly to no avail.
    Old site before it moved:

    Create a blogs.dir directory at /home/bwmtest/domains/bwmtest.nl/public_html/k9gta/wp-content/blogs.dir. This directory is used to store uploaded media for your additional sites and must be writeable by the web server.

    Add the following to your wp-config.php file in /home/bwmtest/domains/bwmtest.nl/public_html/k9gta/ above the line reading /* That’s all, stop editing! Happy blogging. */

    New site environment

    Create a blogs.dir directory at /home/parksgta/public_html/nieuw/wp-content/blogs.dir. This directory is used to store uploaded media for your additional sites and must be writeable by the web server.

    Add the following to your wp-config.php file in /home/parksgta/public_html/nieuw/ above the line reading /* That’s all, stop editing! Happy blogging. */:

    How it makes some sense. I should mention that I had changed the image upload path and it worked fine in the old server. Tried to put it back but that didn't do it either.
    Thanks in advance

  2. What's the problem?

    You're making /wp-content/blogs.dir/ no matter what, the rest of the path is different because you're on a new server, and each server sets up Home directories a little differently.

  3. leradstar
    Member
    Posted 1 year ago #

    So differently that I can't upload images? I just don't understand what's wrong. As you can see (or not) the first path consist of a domain name and the second not.
    I appreciate the reply but don't think I'm pointing to the problem correctly. All images from the previous installation are there. I don't get an error at all but the new images are not visible in the library, only when I chose edit further. There is something wrong with the part before the ..../wp-content/blogs.dir
    As I said, the images for the 1st blog are stored in a separate folder and the secondary blog images are stored in the usual path.
    Perhaps if I provide a link you'll be able to see it
    http://k9gta.com/nieuw
    Click on the spanish flag version to see the difference (the path is correct there) and I can load images - but not in the ENG version.
    If nothing works, how can I revert to the correct path?

    Thanks

  4. As you can see (or not) the first path consist of a domain name and the second not.

    I promise, that's not a problem :) Toss it out of your head for now.

    The part before wp-content is always server specific, and WordPress itself does not use it. It's not hard coded anywhere. If it was, you'd never be able to move your site. Ick.

    here is something wrong with the part before the ..../wp-content/blogs.dir

    There's nothing wrong, it's not a part of the problem at all. Forget about it.

    All images from the previous installation are there. I don't get an error at all but the new images are not visible in the library, only when I chose edit further.

    Okay, here's what I need.

    1) A direct link to a page with images that works
    2) A direct link to a page with images that DOES NOT work.

    As I said, the images for the 1st blog are stored in a separate folder and the secondary blog images are stored in the usual path.

    That tells me, generally, that your .htaccess isn't working correctly, but I need to see it to tell you more.

  5. leradstar
    Member
    Posted 1 year ago #

    Hi Ipstenu,

    I agree, the .htaccess doesn't seem to be working correctly and I don't seem to know all the steps either. This is how the url path was

    /home/parksgta/k9gta.com/public_html/nieuw/k9imgs

    And this is what I changed

    /home/parksgta/public_html/nieuw/k9imgs

    Having taken over someone else's site, there was a folder in cPanel (still) is with the same name as the domain and all the images were going to that folder. Haven't been able to delete the folder, it keeps recreating itself even after renaming it. Indeed everything before ..../wp-content/blogs.dir has nothing to do with it.
    All I can say, WordPress wasn't the problem. It is resolved for now. I can upload and use images. Remains to be seen what will happen when I move it to root.
    Thank you for your quick response, surely learnt a lot and MU isn't so daunting as I thought.

    Kind regards,

  6. The URL path... where?

    Because nowhere in a default WP install will you ever see that path, unless you edited it in media settings when your site was a single install.

  7. leradstar
    Member
    Posted 1 year ago #

    Yes I did edit the path for one site, didn't like the default year, month folder structure in media settings. Can be a bit annoying when searching for images in ftp. In the future, I will not edit media settings until the site has been moved to the root folder.

  8. Yeah. We really don't suggest messing with that because it's a hassle to edit back.

    Now of note: If I don't know how you edited things, I can't tell you how to fix them ;) Hence the run around we had

    Okay, go into wp-admin/network/

    Click on sites.

    Edit the site in question.

    Go to Settings

    Now in there is where it stores the URL path (but only if you'd changed it, otherwise it dynamically picks up the defaults)

  9. leradstar
    Member
    Posted 1 year ago #

    Even bigger problem, don't know if I should start a new thread for this?

    Having moved the site to root can't access network admin.
    Been reading a lot in the forum but nothing helps. Have exactly the same problem described here
    http://wordpress.org/support/topic/wrong-network-admin-url?replies=23

    I am on a UNIX server with cPanel. Now the second blog doesn't show and all plugins are network enabled so I can't disable them.
    I dead!

  10. Did you actually move the site?

    And when you did it, did you follow these directions? http://codex.wordpress.org/Moving_WordPress#Moving_WordPress_Multisite

  11. leradstar
    Member
    Posted 1 year ago #

    Sorry for a very late reply.
    I followed those instructions from one host to another (in a sub-folder). The problem arose when moving it to root. I have now disabled the MU and will re-install it later. Probably best to always install MU to an existing site. The move is a stressful thing indeed.

Topic Closed

This topic has been closed to new replies.

About this Topic